This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 50999 - avma1_cs modul is missing
avma1_cs modul is missing
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-06 09:50 EDT by Bernd Bartmann
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-16 12:32:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2001-08-06 09:50:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
card service modul for the AVM Fritz!PCMCIA ISDN card is missing, but 
hisax support is enabled

How reproducible:
Always

Steps to Reproduce:
1. Install a AVM Fritz!PCMCIA ISDN card
2. Watch the messages in /var/log/messages from the card manager
3.
	

Additional info:
Comment 1 Glen Foster 2001-08-06 18:52:07 EDT
We (Red Hat) really need to fix this defect before next release.
Comment 2 Arjan van de Ven 2001-08-15 17:12:36 EDT
Hmm all I've been able to find is other people mentioning the driver....
No driver code itself. Do you have any idea where it might be hiding ?
Comment 3 Bernd Bartmann 2001-08-16 04:28:11 EDT
There is a patch for the pcmcia-cs package available to add support for the 
Fritz!PCMCIA card at http://www.wimmer-net.de/avm-pcmcia/
Please have a look at the README at http://www.wimmer-net.de/avm-pcmcia/README
Comment 4 Arjan van de Ven 2001-08-16 06:12:06 EDT
Thanks for the URL.
It seems that at least the driver for your card is already included, but with 
a different name (sigh :)
Would you mind replacing "avma1_cs" with "avm_a1p" in your /etc/pcmcia config
files and see if that works ? If it does, I'll fix the config file for the next
build; if it doesn't, well I'll figure something else.
Comment 5 Kai Engert (:kaie) 2001-08-16 11:22:46 EDT
I had the same problem last weekend, however with RedHat 7.1. My understanding
is: Package kernel-pcmcia-cs already contains everything that is required and
don't needs a patch. The kernel itself it missing a module.

Module avm_a1p, which is linked into module hisax, didn't help on my system.

In Message http://uwsg.iu.edu/hypermail/linux/kernel/0103.1/0957.html, an
attachment http://uwsg.iu.edu/hypermail/linux/kernel/0103.1/att-0957/01-avmdiff
is included, that worked immediately on my system.

It provides the module avma1_cs that is referenced by kernel-pcmcia-cs.
Comment 6 Bernd Bartmann 2001-08-16 12:32:49 EDT
Renaming the entries /etc/pcmcia/config from "avma1_cs" to "avm_a1p" doesn4t
solve the problem. The module "avm_a1p" is only the hisax code for accessing the
registers on the ISDN controller chip. But to make this card work you also need
the activation and IRQ/port setup code from the avma1_cs card service module.
The patch mentioned in the comment from kai.engert@gmx.de seems to be the same
as the one in my last comment.
Comment 7 Arjan van de Ven 2001-08-20 08:16:33 EDT
Added this module; should be in kernels with version 2.4.7-2.5 or later, which
should appear in rawhide sometime later this week / early next week.
Thanks for the help on this one!
(please reopen the bug if this kernel doesn't make it work for you please)
Comment 8 Bernd Bartmann 2001-08-28 05:37:37 EDT
Thanks!!!
I just installed kernel 2.4.7-2.9 from rawhide and the card now works as 
expected.

Note You need to log in before you can comment on or make changes to this bug.