Bug 510009 - Using radeon causes laptop to over heat
Using radeon causes laptop to over heat
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 08:10 EDT by FranciscoMendonça
Modified: 2018-04-11 15:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-14 19:03:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description FranciscoMendonça 2009-07-07 08:10:00 EDT
Description of problem:
Fedora 11 x86 or i386 live cd/install on a Asus F8s with an Ati Mobility HD2600 card overheats when using the  RadeonHD drivers.

Version-Release number of selected component (if applicable):
The one shipped on F11 live cd and the latest one on updates. (Sorry I cannot specify but had to downgrade to F10 to use the proprietary drivers)


Steps to Reproduce:
1. Pop your live cd into the cd drive.
2. Boot.
3.Wawww Fedora!!!!
4. Install the gnome sensor applet and check the cpu temperature.
5. Watch it rise above 100ºC and be afraid.
  
Actual results:
Laptop Fans go berserk trying to cool down the laptop. It eventually overheats and the kernel forces a shutdown. 
You can boot again to see several messages complaining about the temperature.

Expected results:
Cold and cool laptop running the latest Fedora. 

Additional info:

My guess (an uneducated guess)  is that for whatever reason the graphic card fans aren't working causing the card to overheat and being a laptop the heat spreads everywhere.

Using the ATI or Radeon drivers causes the same problem. (Do they use the same code to support this card?).
You have the same behaviour on an updated F10. I was an early adopter of F10 and used the open drivers (no alternative) and didn't had this problem. Then I changed to the proprietary ones for more functionality and never went back until F11. When I downgraded to F10 I tried once again the open drivers and got the mentioned issue.

This is a very serious bug. It blocks F11 from users using this card and F10 for those who don't want to use ati's proprietary drivers.

I'm not reinstalling F11 until this is solved or the proprietary  drivers become available  but I can always boot the live cd for testing. So if you need more info or testing on my part, do no hesitate to ask.

Francisco Mendonça
Comment 1 Hans Ulrich Niedermann 2009-07-08 07:09:17 EDT
I am quite certain the Live CD is not shipping the xorg-x11-drv-radeonhd package with the radeonhd driver.

Reassigning to the xorg-x11-drv-ati package which ships the radeon driver, which is the one Fedora officially supports.
Comment 2 Hans Ulrich Niedermann 2009-07-08 07:13:59 EDT
The priority should be to make sure Fedora's kernel and default userspace driver bits work together well out of the box.

radeonhd can come second.
Comment 3 Matěj Cepl 2009-11-05 13:34:22 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 4 Chris Campbell 2009-12-16 13:40:02 EST
Francisco, can you verify your load and load source, please? Also, if this bug is still a reproduceable one, please attach the logs as listed below.



Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Matěj Cepl 2010-02-26 07:26:18 EST
Could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[Note please, that this is machine generated comment for large amount of bugs; due to some technical issues, it is possible we've missed some of the responses -- it is happens, please, just a make a comment about that; that we will see. Thank you]
Comment 6 Bug Zapper 2010-04-27 11:31:45 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Chris Campbell 2010-06-14 19:03:24 EDT
Since there are insufficient details provided in this report for us to investigate the issue further, and we have not received feedback to the information we have requested above, we will assume the problem was not reproducible, or has been fixed in one of the updates we have released for the reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest update of their distribution, and if this issue turns out to still be reproducible in the latest update, please reopen this bug with additional information.

Closing as INSUFFICIENT_DATA.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.