Bug 510013 - (shoom013) problem with RHEL5.4 beta on ia64 installation
problem with RHEL5.4 beta on ia64 installation
Status: CLOSED DUPLICATE of bug 506725
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.4
ia64 Linux
low Severity urgent
: beta
: ---
Assigned To: Radek Vykydal
Release Test Team
http://www.hemofarm.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 08:36 EDT by Zoran Popovic
Modified: 2009-07-30 08:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-30 08:21:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zoran Popovic 2009-07-07 08:36:07 EDT
Description of problem:

I have downloaded RHEL 5.4 beta for IA64 and tried to install it on a rx4640 (Montecito) where I have already installed successfully RHEL5.3, and got the following error:
> /usr/lib/anaconda/text.py(561)partedExceptionWindow()
-> if anaconda.isKickstart and exc.type == parted.EXCEPTION_WARNING and \
serial console output:
                                                              ERROR: pdc: reading /dev/sda[Input/ou                                         
                                                             put/output error]
                 +-----------+ Exception Occurred +-----------+               ERROR: pdc: reading|                                            |
                 | Traceback (most recent call first):        | g /dev/sda[Input/output error]   |   File "/usr/lib/anaconda/text.py", line   |
              ERR| 561, in partedExceptionWindow              |
                 |     if anaconda.isKickstart and exc.type   | ROR: pdc: reading /dev/sda[Input/| == parted.EXCEPTION_WARNING and \          |
                 | NameError: global name 'anaconda' is not   | /output error]
                 | defined                                    |               ERROR: pdc: reading|                                            |
                 |                                            | g /dev/sda[Input/output error]   |                                            |
              ERR|       +----+              +-------+        |
                 |       | OK |              | Debug |        | ROR: pdc: reading /dev/sda[Input/|       +----+              +-------+        |
                 |                                            | /output error]
                 |                                            |               ERROR: sil: reading+--------------------------------------------+
                                                                g /dev/sda[Input/output error]                                               

BTW, trying to use linux mpath gives even worse error - somtehing like unable to find anaconda ...


Version-Release number of selected component (if applicable):
-

How reproducible:
every time

Steps to Reproduce:
1. begin fresh installation from RHEL5.4 beta IA64 media
2. after entering subscription code, during parted configuration it crashes

  
Actual results:
installation impossible

Expected results:
at least workaround (how to omit parted - I can use old disk layout ?) in order to beta-test 

Additional info:
I need this ASAP because I would like to have a better picture about Xen pci passthrough on IA64 before going with proposal to management about RHEL in our company ... or I am just too curious :=) ...
Comment 1 Zoran Popovic 2009-07-07 09:40:42 EDT
Ok, I was making too much panic, yum -y upgrade works fine with DVD - this is a workaround, but the main issue remains.
Comment 2 Chris Lumens 2009-07-07 10:00:43 EDT
Can you please check which version of anaconda you've got?  This should be fixed in anaconda-11.1.2.184.
Comment 3 Zoran Popovic 2009-07-08 04:56:40 EDT
Whatever I have as part of RHEL5.4 beta installation, I will have to check - but even then I will have to change somehow whole installation disk (how ?).
ZP.
Comment 4 Radek Vykydal 2009-07-08 07:21:16 EDT
Please see https://bugzilla.redhat.com/show_bug.cgi?id=506725#c24, the patch for the bug should be available in Snap 1.

As a workaround for beta-testing, you can also try updates file from https://bugzilla.redhat.com/show_bug.cgi?id=506725#c16.
(add updates=http://rvykydal.fedorapeople.org/updates.506725_2.img to boot parameters.
Comment 5 Zoran Popovic 2009-07-08 08:32:52 EDT
Those two bz links told me: You are not authorized to access bug #506725.
Comment 6 Radek Vykydal 2009-07-08 09:02:37 EDT
Ah, sorry, the bug has restricted visibility. Your issue is probably a duplicate of the referred (inaccessible) bug which will be fixed in Snapshot 1 (should have been fixed in Beta). As I said, you can try to use
updates=http://rvykydal.fedorapeople.org/updates.506725_2.img
as installation boot parameter which should fix the bug for your beta-testing.
Comment 7 Radek Vykydal 2009-07-30 08:21:04 EDT
Closing as duplicate, the bug was fixed in Snapshot 1 or 2.

*** This bug has been marked as a duplicate of bug 506725 ***

Note You need to log in before you can comment on or make changes to this bug.