Bug 510060 - Installation fails while searching for hard disks
Installation fails while searching for hard disks
Status: CLOSED DUPLICATE of bug 501768
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 11:24 EDT by sss
Modified: 2009-07-17 15:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-17 15:59:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output of boot messages during isntallation (15.41 KB, text/plain)
2009-07-08 12:29 EDT, sss
no flags Details
file /tmp/anacdump.txt immediately after the crash (58.31 KB, text/plain)
2009-07-10 22:55 EDT, sss
no flags Details
file /tmp/anaconda.log immediately after the crash (3.42 KB, text/plain)
2009-07-10 22:57 EDT, sss
no flags Details

  None (edit)
Description sss 2009-07-07 11:24:04 EDT
Description of problem:
I am unable to install fedora Core 11 on my HP tx2000 tablet PC. I had downloaded the network installation but it gave an error while scanning for available hard disks during the beginning of the install. I again downloaded the installation DVD which also failed in the same manner giving a python script error.

Version-Release number of selected component (if applicable):
Fedora Core 11

How reproducible:
May be related to hardware configuration.

Steps to Reproduce:
1. Boot the install DVD, select install or upgrade option
2. Begin anaconda installer
3. After keyboard type is selected, a dialog box appears stating that fedora is searching for storage media. At this point an unhandled exception window pops up statign that an error occurred. The only options available are to either save, debug or exit isntaller. 
  
Actual results:
Installer fails

Expected results:
Installer should detect the SATA hard disk of the laptop and begin partitioning section.

Additional info: 250 GB sata hard drive.
Fedora core 10 was installed and working on this laptop earlier. It did not give this error at all.
Comment 1 Andy Lindeberg 2009-07-07 11:38:53 EDT
Can you attach the traceback you got?
Comment 2 sss 2009-07-08 11:03:11 EDT
I am unable to even save the debug details for the exception traceback since anaconda is unable to locate any storage media to save it on.

However, I ran the installer once again and wrote down the traceback details, these are listed as follows:

An unhandled exception occurred.

Details:
Anaconda 11.5.0.59 exception report

Traceback (most recent call first)
File "/usr/lib64/python2.6/site-packages/parted/disk.py" line 142, in duplicate
  return Disk(PedDisk=self.__disk.duplicate() )


Are there any kernel options I can pass via grub to make it recognise my SATA hard disk? That workaround could make the installer work.
Comment 3 sss 2009-07-08 12:29:50 EDT
Created attachment 350964 [details]
dmesg output of boot messages during isntallation

I selected "debug" when the error occurred and started another tty-login on console 2 (Alt+F2). I captured this dump of 'dmesg' from this shell.
This might help debugging the error.
Comment 4 Chris Lumens 2009-07-09 15:19:38 EDT
If you can switch to tty2, you'll see the traceback in /tmp/anacdump.txt.  You can then scp that off to another computer.  In rawhide, we should also now have the ability to ignore the errors when looking for disks to save exceptions to.
Comment 5 sss 2009-07-10 22:55:46 EDT
Created attachment 351321 [details]
file /tmp/anacdump.txt immediately after the crash

file /tmp/anacdump.txt obtained immediately after the crash
Comment 6 sss 2009-07-10 22:57:31 EDT
Created attachment 351322 [details]
file /tmp/anaconda.log immediately after the crash

file /tmp/anaconda.log immediately after the crash
Comment 7 Ruediger Fender 2009-07-14 05:57:38 EDT
I get the same crash on an PATA machine (on my laptop the update worked fine)
Comment 8 Chris Lumens 2009-07-17 15:59:10 EDT

*** This bug has been marked as a duplicate of bug 501768 ***

Note You need to log in before you can comment on or make changes to this bug.