Bug 510063 - Tritonus crashes OpenJDK when using ALSA MIDI
Tritonus crashes OpenJDK when using ALSA MIDI
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tritonus (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 11:30 EDT by Mikhail Kryshen
Modified: 2009-07-16 03:01 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.3.7-0.4.20090419cvs.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-16 02:54:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OpenJDK crash log (22.14 KB, text/plain)
2009-07-07 11:30 EDT, Mikhail Kryshen
no flags Details

  None (edit)
Description Mikhail Kryshen 2009-07-07 11:30:37 EDT
Created attachment 350822 [details]
OpenJDK crash log

Description of problem:
When Java application tries to list available MIDI devices (MidiSystem.getMidiDeviceInfo()) while having tritonus_alsa in the classpath OpenJDK crashes. See the attached log.

Test Java code:

import javax.sound.midi.*;
import java.util.*;

public class MidiTest1 {
    public static void main(String[] args) {
        System.out.println(Arrays.toString(MidiSystem.getMidiDeviceInfo()));
    }
}


Version-Release number of selected component (if applicable):
tritonus-0.3.7-0.3.20090419cvs.fc11.x86_64
java version "1.6.0_0"
OpenJDK Runtime Environment (IcedTea6 1.5) (fedora-22.b16.fc11-x86_64)
OpenJDK 64-Bit Server VM (build 14.0-b15, mixed mode)

How reproducible:
Always

Steps to Reproduce:
1. Compile the test java program
2. Run java -cp .:/usr/lib64/tritonus/tritonus_core.jar:/usr/lib64/tritonus/tritonus_share.jar:/usr/lib64/tritonus/tritonus_alsa.jar:/usr/lib64/tritonus/tritonus_aos.jar MidiTest1
3. OpenJDK crashes.
  
Actual results:
OpenJDK crashes.

Expected results:
List of the available MIDI devices, including ALSA devices.

Additional info:
Without tritonus the same application outputs
[Gervill, Real Time Sequencer]
Comment 1 Orcan Ogetbil 2009-07-07 16:52:10 EDT
Thanks for the report.
 
I verified the crash. It doesn't look like this is a packaging bug. It is a bug in the software itself and there is not much I can do as I'm not a tritonus developer. Did you report this upstream?

I'll be happy to apply a patch if you can find or write one.
Comment 2 Orcan Ogetbil 2009-07-07 19:16:03 EDT
We tried to make a quick fix. I'm not sure if it is the best one.
Could you try this scratch build from koji
   http://koji.fedoraproject.org/koji/taskinfo?taskID=1460556
You can upgrade directly.

Thanks!
Comment 3 Mikhail Kryshen 2009-07-07 20:41:29 EDT
The new build works for me: I tried to list midi devices and send midi commands from java. Thank you!

I haven't reported this bug upstream. Tritonus bug tracker at sourceforge looks abandoned.
Comment 4 Fedora Update System 2009-07-08 04:37:21 EDT
tritonus-0.3.7-0.4.20090419cvs.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/tritonus-0.3.7-0.4.20090419cvs.fc9
Comment 5 Fedora Update System 2009-07-08 04:38:31 EDT
tritonus-0.3.7-0.4.20090419cvs.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/tritonus-0.3.7-0.4.20090419cvs.fc10
Comment 6 Fedora Update System 2009-07-08 04:40:21 EDT
tritonus-0.3.7-0.4.20090419cvs.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/tritonus-0.3.7-0.4.20090419cvs.fc11
Comment 7 Fedora Update System 2009-07-16 02:54:53 EDT
tritonus-0.3.7-0.4.20090419cvs.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-07-16 03:01:46 EDT
tritonus-0.3.7-0.4.20090419cvs.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.