Bug 510083 - nfs4 mount fails without ipv6.ko loaded: mount(2): Cannot allocate memory
nfs4 mount fails without ipv6.ko loaded: mount(2): Cannot allocate memory
Status: CLOSED DUPLICATE of bug 504602
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 12:18 EDT by Matt Bernstein
Modified: 2009-07-07 15:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-07 15:11:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of odd behaviour (5.17 KB, image/png)
2009-07-07 12:18 EDT, Matt Bernstein
no flags Details

  None (edit)
Description Matt Bernstein 2009-07-07 12:18:10 EDT
Created attachment 350830 [details]
screenshot of odd behaviour

Description of problem: 

I've disabled IPv6 ("install ipv6 /bin/true" in /etc/modprobe.d/blacklist.conf).

I wish to mount an IPv4 nfs4 share. It only works after loading the ipv6 kernel module. But that means I need to worry about IPv6, and I'm not ready to do that.

Version-Release number of selected component (if applicable):

nfs-utils-1.1.5-6.fc11.x86_64
kernel-2.6.29.5-191.fc11.x86_64

How reproducible: always

Steps to Reproduce:
1. /etc/init.d/rpcidmapd start
2. mount -v -t nfs4 brie:/test /mnt
  
Actual results:

mount.nfs4: mount(2): Cannot allocate memory
mount.nfs4: Cannot allocate memory

Expected results:

brie:/test on /mnt type nfs4 (rw)

Additional info:

Googling suggested ipv6 "fixed" this. I've no idea why, and I don't consider it a fix.
Comment 1 Steve Dickson 2009-07-07 15:11:36 EDT

*** This bug has been marked as a duplicate of bug 504602 ***

Note You need to log in before you can comment on or make changes to this bug.