Bug 510112 - View raw ouput for *some* events not working
View raw ouput for *some* events not working
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
wes hayutin
https://grandprix.rhndev.redhat.com/n...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 13:53 EDT by wes hayutin
Modified: 2009-07-08 08:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-08 04:56:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ss (183.55 KB, image/png)
2009-07-07 13:53 EDT, wes hayutin
no flags Details

  None (edit)
Description wes hayutin 2009-07-07 13:53:03 EDT
Created attachment 350841 [details]
ss

Description of problem:

This bug *may* only be specific to the proxy webui installer.
not sure..

7/3 build
created in a new org.

1. webui install proxy 530
2. go to history 
3. click on Run an arbitrary script scheduled by 
4. click raw out put..

get blank page..
I *should* get the output of the script.

on another system.. I run a remote command w/ just "ls"
and I can see the remote output.

This bug *may* only be specific to the proxy webui installer.
not sure..

putting on sat530-triage so dev can look, and punt if needed :)
Comment 2 Miroslav Suchý 2009-07-08 04:56:33 EDT
I do confirm this behavior. The page is blank for this action:

1)
#!/bin/sh
chown root.apache /etc/sysconfig/rhn/systemid
chmod 640 /etc/sysconfig/rhn/systemid

2)
#!/bin/sh
for service in jabberd squid httpd; do
/sbin/chkconfig --add $service
if [ "$1" = "1" ] ; then # first install
/sbin/chkconfig --level 345 $service on
fi
done

3)
#!/bin/sh
/usr/sbin/rhn-proxy restart

Coincidentally those action do not produce any output. So Filtered output on the same page is blank. And raw output is blank (blank page) as well.

Actions which produce some output (like removing packages) has correct output in Filtered output and on Raw output as well.

NOT A BUG
Comment 3 Miroslav Suchý 2009-07-08 05:41:22 EDT
Err. Item 3 (proxy restart) should not be listed in comment #2. It produce output. On Filtered output and on raw output.

Note You need to log in before you can comment on or make changes to this bug.