Bug 510127 - perl taint bug
perl taint bug
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 15:08 EDT by Warren Togami
Modified: 2010-01-20 06:26 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-20 06:26:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a patch to work around this bug (414 bytes, patch)
2009-11-24 05:19 EST, Stepan Kasal
no flags Details | Diff

  None (edit)
Description Warren Togami 2009-07-07 15:08:24 EDT
https://issues.apache.org/SpamAssassin/show_bug.cgi?id=6148
Upstream spamassassin says our perl is effected by a tainting bug.  While they have worked around the problem for now, we should verify that Fedora 12 does not generally have this problem.
Comment 1 Marcela Mašláňová 2009-07-27 02:16:58 EDT
In upstream ticket was attached new patch for spam-assassin. Would it be working only with fix in SA or have I apply patch to perl?
Comment 2 Warren Togami 2009-07-27 12:00:10 EDT
They are working around it in spamassassin, but they point out that this is a bug in perl.
Comment 3 Marcela Mašláňová 2009-07-28 04:02:54 EDT
This should be fixed in rawhide. Please test the latest perl build with patch mentioned in upstream spam assassin ticket. 
http://koji.fedoraproject.org/koji/taskinfo?taskID=1547911
Comment 4 Marcela Mašláňová 2009-07-30 08:56:03 EDT
Please let me know whether this change helped.
Comment 5 Marcela Mašláňová 2009-09-14 10:23:44 EDT
Ping?

The workaround is in perl package. What's the correct solution? They will fix it in upstream of perl or upstream of spamassassin?
Comment 6 Marcela Mašláňová 2009-10-21 02:16:08 EDT
I applied patch long time ago, so I believe it's working if no-one had any comments. Closing bug for F-12 with fix in perl-4:5.10.0-77 and higher.
Comment 7 Stepan Kasal 2009-11-24 05:19:47 EST
Created attachment 373380 [details]
a patch to work around this bug

For the record, this is that patch introduced in perl-5.10.0-77.
Comment 8 Stepan Kasal 2009-11-24 08:11:40 EST
The attachment from perl-5.10.0-77 proved to cause weird problems, see bug #528572, so it is safer to back it out.  It was a workaround for one particular instance of the problem, anyway.

The real problem is discussed upstream:
http://rt.perl.org/rt3//Public/Bug/Display.html?id=67962

As of now, no solution for this bug is available.

Since SpamAssassin contain a work aruound for this issue, I do not think this has to be F-12 blocker.
Comment 9 Marcela Mašláňová 2010-01-20 06:26:42 EST
I suppose this was also fixed by perl-5.10.1.

Note You need to log in before you can comment on or make changes to this bug.