Bug 510185 - vncviewer ignores -LowColourLevel switch
vncviewer ignores -LowColourLevel switch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 04:41 EDT by Tom Hughes
Modified: 2013-04-30 19:43 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.0.0-3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 02:34:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Hughes 2009-07-08 04:41:59 EDT
Description of problem:

vncviewer ignores the -LowColourLevel switch and uses a 24 bit full colour connection.

Version-Release number of selected component (if applicable):

tigervnc-0.0.91-0.11.fc11.x86_64

How reproducible:

Every time.

Steps to Reproduce:
1. Run "vncviewer -LowColourLevel 2 <host>".
2. Note that the output says "Using pixel format depth 24 (32bpp) little-endian rgb888".
3. Note that the view takes ages to redraw if the host is on a slow link.
  
Actual results:

A full colour connection is used.

Expected results:

The requested connection type is used.

Additional info:

It seems that the old realvnc client in previous releases had the same problem - the only difference was that it defaulted to an 8bpp connection instead of a 32bpp connection.
Comment 1 Adam Tkac 2009-10-07 11:06:28 EDT
After discussion in upstream this is actually not a bug but a feature. When you would like to use reduced color level you have to specify also -AutoSelect=0 parameter.

Main reason is that some users would like to use auto select mode and would like to control which reduced color level is used when autoselecting code decides to switch to reduced color level.

Currently there is another bug in code - you have to use -FullColor=0 in addition to -AutoSelect=0 parameter to get -LowColorLevel working as you wish. This will be fixed in the next release.

You can read the full story on http://www.mail-archive.com/tigervnc-devel@lists.sourceforge.net/msg00395.html.
Comment 2 Fedora Update System 2009-10-08 10:29:20 EDT
tigervnc-1.0.0-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/tigervnc-1.0.0-1.fc11
Comment 3 Fedora Update System 2009-10-13 21:37:18 EDT
tigervnc-1.0.0-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tigervnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10416
Comment 4 Fedora Update System 2009-10-27 02:33:53 EDT
tigervnc-1.0.0-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2009-11-16 09:56:15 EST
tigervnc-1.0.0-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/tigervnc-1.0.0-3.fc12
Comment 6 Fedora Update System 2009-12-01 23:43:42 EST
tigervnc-1.0.0-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.