Bug 510189 - SPICE | Linux guest | ASSERT when rebooting the guest. VM destroyed.
SPICE | Linux guest | ASSERT when rebooting the guest. VM destroyed.
Status: CLOSED DUPLICATE of bug 509410
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-qxl (Show other bugs)
5.4
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Søren Sandmann Pedersen
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 05:22 EDT by Leonid Natapov
Modified: 2016-04-18 02:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-15 16:16:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log (8.27 MB, application/octet-stream)
2009-07-08 05:22 EDT, Leonid Natapov
no flags Details

  None (edit)
Description Leonid Natapov 2009-07-08 05:22:39 EDT
Created attachment 350907 [details]
vdsm.log

How to reproduce:
1.Connect to Linux guest VM.
2.Exit Window Manager.
3.Reboot the VM.

Here is the stdio output
------------------------
vdi_port_io_map: base 0xc140 size 0x10
vdi_port_ram_map: addr 0xc1000000 size 0x10000
ram_map: addr 0xc4000000 size 0x4000000
vram_map: addr 0xc8000000 size 0x1000
rom_map: addr 0xc8002000 size 0x2000
ioport_map: base 0xc150 size 0x8
qxl_display_resize
qxl_reset
handle_dev_input: detach
qxl_reset_state: ASSERT RING_IS_EMPTY(&ram->cmd_ring) failed
interface_audio_fini:
interface_change_notifier: remove VD_INTERFACE_PLAYBACK
interface_change_notifier: remove VD_INTERFACE_RECORD


vdsm.log attached
Comment 1 Yaniv Kaul 2009-07-09 05:56:39 EDT
Is it with QXL driver on the X? Please specify.
Comment 2 Leonid Natapov 2009-07-09 06:33:36 EDT
With QXL driver.
Comment 5 Yaniv Kaul 2009-07-14 08:07:49 EDT
Apparently, a driver bug.
Comment 6 Søren Sandmann Pedersen 2009-07-15 01:28:54 EDT
What does "exit the Window Manager" mean specifically? What precisely do you do?
Comment 7 Søren Sandmann Pedersen 2009-07-15 03:02:50 EDT
Also are there any earlier messages from qemu? Such as 

   "ioport_write: unexpected port 0x1 in vga mode"

If so, this is the same issue as bug 509410.
Comment 8 Leonid Natapov 2009-07-15 06:08:12 EDT
Yes,there are "ioport_write: unexpected port 0x1 in vga mode" messages prior the ASSERT. I mean, when I kill window manager (CTRL-ALT-BACKSPACE or init 3) I can see those messages in stdio file on the server. When I reboot the VM afterwards I get an ASSERT.
Comment 9 Søren Sandmann Pedersen 2009-07-15 16:16:55 EDT

*** This bug has been marked as a duplicate of bug 509410 ***

Note You need to log in before you can comment on or make changes to this bug.