Bug 510192 - time-record-tt: Fix ltrace testsuite, or ltrace itself
time-record-tt: Fix ltrace testsuite, or ltrace itself
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ltrace (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Petr Machata
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 05:42 EDT by Michal Nowak
Modified: 2015-05-04 21:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 10:06:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for this issue (929 bytes, patch)
2012-10-01 12:30 EDT, Petr Machata
no flags Details | Diff

  None (edit)
Description Michal Nowak 2009-07-08 05:42:29 EDT
Description of problem:

ltrace testsuite sometimes fails when performing test `time-record-tt`:

[...]
Running ./ltrace.minor/time-record-tt.exp ...
FAIL: Start at 91, End at 91, but PUT call nanosleep(50)!

Version-Release number of selected component (if applicable):

ltrace-0.5-13.45svn.el5

How reproducible:

frequently
  
Actual results:

FAIL: Start at 91, End at 91, but PUT call nanosleep(50)!

or similar

Expected results:

"PASS"

Additional info:

Full log: http://rhts.redhat.com/testlogs/70207/222716/1822165/TESTOUT.log

According to:

https://errata.devel.redhat.com/errata/show/7912#c17 the problem might be the testsuite or possibly ltrace itself.
Comment 3 RHEL Product and Program Management 2010-08-09 15:07:03 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 Petr Machata 2012-10-01 12:30:45 EDT
Created attachment 619875 [details]
Fix for this issue

This is upstream patch which should fix this issue.  Porting this, if necessary at all, should be trivial.
Comment 6 Jeff Law 2013-11-13 10:06:03 EST
This Bugzilla has been reviewed by Red Hat and is not planned on being
addressed in Red Hat Enterprise Linux 5, and therefore will be closed.
If this bug is critical to production systems, please contact your Red
Hat support representative and provide sufficient business
justification.

Note You need to log in before you can comment on or make changes to this bug.