Bug 510194 - febootstrap: UnicodeDecodeError when rpm_check_debug is run
febootstrap: UnicodeDecodeError when rpm_check_debug is run
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: febootstrap (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 06:19 EDT by Richard W.M. Jones
Modified: 2010-12-05 01:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-05 01:44:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 536214 None None None Never

  None (edit)
Description Richard W.M. Jones 2009-07-08 06:19:34 EDT
Originally reported in Debian BTS:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=536214

Package: febootstrap
Version: 2.1-4
Severity: normal


While bootstrapping a fedora-11 system I get the following traceback

$ febootstrap fedora-11 f11

[...]

ERREUR de résolution de dépendance par rpm_check_debug :
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 261, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 424, in doTransaction
    print to_utf8(msg)
  File "/usr/lib/python2.5/codecs.py", line 303, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 25: ordinal not in range(128)

I'm going to try out with a different LAN and LC_CTYPE to see if it works... 

This might be a bug in yum, please reaffect it if it is the case. 


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.26-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set to fr_FR.UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages febootstrap depends on:
ii  cpio                          2.9.90-3   GNU cpio -- a program to manage ar
ii  fakechroot                    2.9-1      gives a fake chroot environment
ii  fakeroot                      1.12.2     Gives a fake root environment
ii  yum                           3.2.23-1   Advanced front-end for rpm

febootstrap recommends no packages.

Versions of packages febootstrap suggests:
ii  gnome-utils                   2.26.0-1   GNOME desktop utilities
ii  makedev                       2.3.1-88   creates device files in /dev
ii  qemu                          0.10.4-1   fast processor emulator
pn  upx-nrv                       <none>     (no description available)

-- no debconf information
Comment 1 Richard W.M. Jones 2009-07-08 06:21:12 EDT
I tried to reproduce this using:

$ LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 febootstrap fedora-11 f11

However it worked for me (using a Fedora host).
Comment 2 Richard W.M. Jones 2009-07-08 06:26:30 EDT
(In reply to comment #1)
> $ LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 febootstrap fedora-11 f11
                    ^
I even tried it without the extra comma and it still works for me.

Googling around, I think this is a problem with the yum metadata
(downloaded XML files).  Maybe clear your HTTP cache and try again?
Comment 3 Bug Zapper 2009-11-16 05:43:52 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2010-11-04 06:49:48 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2010-12-05 01:44:16 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.