This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 510210 - evince fails to handle /Decode in PDF files
evince fails to handle /Decode in PDF files
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evince (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Marek Kašík
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 07:31 EDT by Miroslav Vadkerti
Modified: 2014-09-08 08:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:00:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
LZW compressed TIFF image (612.33 KB, image/tiff)
2009-07-08 07:32 EDT, Miroslav Vadkerti
no flags Details

  None (edit)
Description Miroslav Vadkerti 2009-07-08 07:31:13 EDT
Description of problem:
When trying to convert LZW compressed TIFF image to pdf with inverted colors (-i option) the output is a blank - white pdf. 

Version-Release number of selected component (if applicable):
libtiff-3.8.2-7.el5_3.3
libtiff-3.6.1-12.el4_8.3
libtiff-3.8.2-13.fc11

How reproducible:
always

Steps to Reproduce:
1. Get a TIFF LZW compressed image (attached lzw.tif)
2. tiff2pdf -i lzw.tif -o lzw.pdf
3. view lzw.pdf with a viewer (e.g. evince)
  
Actual results:
White - blank pdf.

Expected results:
PDF with inverted colors image as with not compressed TIFF image.

Additional info:
When converting TIFF without a compression the output is ok. This bug appers on RHEL-4, RHEL-5 and also in FEDORA (tested on FC11).
Comment 1 Miroslav Vadkerti 2009-07-08 07:32:41 EDT
Created attachment 350916 [details]
LZW compressed TIFF image
Comment 2 Tom Lane 2010-06-13 21:17:16 EDT
As near as I can tell, this is not a libtiff bug.  What tiff2pdf does with -i is just to put a line like this into the output:

/Decode [ 1 0 1 0 1 0 1 0 ]

so it's just relying on the PDF viewer to perform the color transformation.  I don't have a "real" Adobe PDF reader at hand, but when I look at the resulting file with Apple's Preview, the colors do get inverted.  So I think what you've got here is a viewer deficiency, and you should complain about whatever PDF viewer you're using.  I concur that evince in particular isn't getting it right, so I'll reassign this bug there.

BTW, I don't observe any effect at all of compressing or not compressing the image, when testing this with libtiff 3.9.2.  Possibly there was some issue there with older releases.
Comment 3 RHEL Product and Program Management 2014-03-07 08:32:06 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 4 RHEL Product and Program Management 2014-06-02 09:00:56 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.