Bug 510224 - Preupgrade F10 -> F11 crash
Preupgrade F10 -> F11 crash
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:c9e2f87b6fef9b5bc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 08:23 EDT by Jacek Piskozub
Modified: 2010-04-19 11:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-17 15:50:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (172.13 KB, text/plain)
2009-07-08 08:23 EDT, Jacek Piskozub
no flags Details
Attached traceback automatically from anaconda. (219.29 KB, text/plain)
2010-04-19 11:14 EDT, Bill Somerville
no flags Details

  None (edit)
Description Jacek Piskozub 2009-07-08 08:23:26 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/__init__.py", line 1769, in mkDevRoot
    dev = "%s/%s" % (instPath, root.path)
  File "/usr/lib/anaconda/upgrade.py", line 314, in upgradeMountFilesystems
    anaconda.id.storage.fsset.mkDevRoot(anaconda.rootPath)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 227, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1372, in setScreen
    (step, anaconda) = self.anaconda.dispatch.currentStep()
  File "/usr/lib/anaconda/gui.py", line 1534, in setup_window
    self.setScreen()
  File "/usr/lib/anaconda/gui.py", line 1544, in run
    self.setup_window(runres)
  File "/usr/lib/anaconda/gui.py", line 1292, in run
    self.icw.run (self.runres)
  File "/usr/bin/anaconda", line 965, in <module>
    anaconda.intf.run(anaconda)
AttributeError: 'NoneType' object has no attribute 'path'
Comment 1 Jacek Piskozub 2009-07-08 08:23:33 EDT
Created attachment 350921 [details]
Attached traceback automatically from anaconda.
Comment 2 Jacek Piskozub 2009-07-08 08:30:45 EDT
Just a vanilla F10 -> F11 upgrade. IMHO connected to the Nvidia card I have on the system (NV44A - GeForce 6200). It happened during the X startup, a few seconds after the anaconda started.
Comment 3 Jacek Piskozub 2009-07-08 08:35:38 EDT
Correction: it also happeded in text mode (I  attached "3" to the preupgrade line in /etc/grub.conf)
Comment 4 Chris Lumens 2009-07-09 13:54:11 EDT
Looks like you have an fstype of "auto" for /dev/sdb1 in your fstab which also happens to be your root partition.  Is this correct?  If so, what happens if you change auto to be the real filesystem type?
Comment 5 Jacek Piskozub 2009-07-09 15:16:55 EDT
Funny thing. I really had those two lines in my /etc/fstab:



LABEL=/                 /                       ext3    defaults        1 1 defaults,umask=022,uid=500,gid=500 0 0

/dev/sdb1               /mnt/usbdrive           auto    user,noauto,umask=000,uid=500,gid=500 0 0

The second one comes from rather ancient times of early kernel space USB memory support. My boot partition at the time was called hdb1. The bad luck is it is now called sdb1 like what Fedora used to detect my memory stick as in the Cretaceous. 

You ask "If so, what happens if you change auto to be the real filesystem type?". That is I can delete the second line right away. The problem is I already did a yum upgrade to F11.

The only way I could (probably) test this would be to force a downgrade of fedora-release to the F10 version to fool preupgrade into allowing me upgrading to F11 (I do not wish to go rawhide on that box). 

Do you think it's worth the hassle? Especially as I would need to change my keyboard in /etc/sysconfig/keyboard from KEYTABLE="pl" to "us" before the preupgrade to avoid another anaconda crash (a problem most probably worth reporting in a new bug as I consistently seen it in four different F10 -> F11 upgrades).
Comment 6 Chris Lumens 2009-07-10 11:36:05 EDT
This is probably a bit of a corner case, so I'm not sure how much time it's worth spending on the issue.  If you've already got your upgrade complete and are happy with the state of things, I don't see any reason why you should go through the pain of downgrading things followed by doing another upgrade.  That seems very likely to leave you with a broken something.
Comment 7 Bill Somerville 2010-04-19 11:14:38 EDT
Created attachment 407616 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.