Bug 510250 - Wrong versions of packages installed after upgrade to Rawhide
Wrong versions of packages installed after upgrade to Rawhide
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 09:35 EDT by Quentin Armitage
Modified: 2014-01-21 18:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-08 09:47:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Quentin Armitage 2009-07-08 09:35:49 EDT
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2)

Description of problem:
After installing Fedora 11, some days later applying all latest patches for F11, and then moving to Rawhide, some packages are not updated to Rawhide version.




Reproducible: Always

Steps to Reproduce:
1. Install F11
2. Apply all F11 updates
3. Enable Rawhide repo and disable F11 repos
4. yum update

Actual Results:  
Some packages not updated to F12 version (see below)

Expected Results:  
All applicable updates should be applied

There appear to be two amonolies in package updates, one of which appears to be controlled by yum/rpm, the other of which is not a yum/rpm issue, but I don't know where to report it. Below are specific examples of packages, but these appear to be generic problems relating to the version numbers and not the packages themselves.

1. (yum/rpm issue). (Example jetty). The install of F11 installed jetty-5.1.14-3.fc11.i586. A subsequent yum update updated jetty to jetty-5.1.15-4.fc11. Following switch to Rawhide, jetty-5.1.15-3.fc12 is available, but because 5.1.15-4 is greater than 5.1.15-3, the fc11 version is seen as later than the fc12 version. Should it not be the case that any fc12 version is considered later than any fc11 version?

2. (Repository issue). (Example ypbind). The install of F11 installed ypbind-1.20.4-18.fc11. A subsequent yum updated updated to 1.20.4-19.fc11. Following switch to Rawhide, latest version in Rawhide repo is 1.20.4-18.fc11, so Rawhide version is earlier than current F11 version.
Comment 1 seth vidal 2009-07-08 09:47:33 EDT
versions are determined by comparing:

the package epoch
the package version
the package release

in that order.

in the first example you gave:
in f11 jetty is ver 5.1.15 its release is 4.fc11
in rawhide jetty is ver 5.1.15 its release 3.fc12

releases are compared left to right. Since 3 is < 4 - then the version of jetty in rawhide is not an update to the version in f11. The tag 'fc12' is just a string - it has no special power.


for the second example you should file that with the specific package in question.

Note You need to log in before you can comment on or make changes to this bug.