Bug 510255 - Review Request: cobertura - a Java tool for calculating the test coverage
Summary: Review Request: cobertura - a Java tool for calculating the test coverage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 510128
TreeView+ depends on / blocked
 
Reported: 2009-07-08 13:58 UTC by Victor G. Vasilyev
Modified: 2009-09-11 23:28 UTC (History)
4 users (show)

Fixed In Version: 1.9-3.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-13 00:39:45 UTC
kevin: fedora-review+
kevin: fedora-cvs+


Attachments (Terms of Use)

Description Victor G. Vasilyev 2009-07-08 13:58:49 UTC
Spec URL: http://victorv.fedorapeople.org/files/cobertura.spec
SRPM URL: http://victorv.fedorapeople.org/files/cobertura-1.9-1.fc12.src.rpm
Description: 
Cobertura is a free Java tool that calculates the percentage of code accessed by tests. It can be used to identify which parts of your Java program are lacking test coverage. It is based on jcoverage.

This tool is used by the NetBeans 6.7 platform (netbeans-platform).

Comment 1 Kevin Fenzi 2009-08-07 19:14:59 UTC
I'll take a stab at reviewing this. Look for a review soon.

Comment 2 Kevin Fenzi 2009-08-08 19:27:09 UTC
Very nice spec. ;) I haven't done much in the way of java reviews, but this seems to match all the guidelines pretty nicely. There is one license question I ran into (see below). 

OK - Package meets naming and packaging guidelines
OK - Spec file matches base package name.
OK - Spec has consistant macro usage.
OK - Meets Packaging Guidelines.
See Below - License
See Below- License field in spec matches
See Below- License file included in package
OK - Spec in American English
OK - Spec is legible.
OK - Sources match upstream md5sum:
0b23286374edc1e0a9ed7dd592b0fed3  cobertura-1.9-src.tar.gz
0b23286374edc1e0a9ed7dd592b0fed3  cobertura-1.9-src.tar.gz.orig
OK - BuildRequires correct
OK - Package has %defattr and permissions on files is good.
OK - Package has a correct %clean section.
OK - Package has correct buildroot
      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
OK - Package is code or permissible content.
OK - Packages %doc files don't affect runtime.
OK - Package has rm -rf RPM_BUILD_ROOT at top of %install
OK - Package compiles and builds on at least one arch.
OK - Package has no duplicate files in %files.
OK - Package doesn't own any directories other packages own.
OK - Package owns all the directories it creates.
OK - Package obey's FHS standard (except for 2 exceptions)
OK - No rpmlint output.
OK - final provides and requires are sane.

SHOULD Items:

OK - Should build in mock.
OK - Should have subpackages require base package with fully versioned depend.
OK - Should have dist tag
OK - Should package latest version
OK - Should not use file requires outside of /etc, /bin, /sbin, /usr/bin, or /usr/sbin

Issues:

1. Looking at the files here, it looks like the License should be:
ASL 1.1 and GPLv2+
The ant parts seem to be under the ASL1.1, and the rest is GPLv2 or later.
Unless there is something I am missing there...

Comment 3 Victor G. Vasilyev 2009-08-09 02:20:27 UTC
Kevin,

Thanks for review!
 
(In reply to comment #2)
> Issues:
> 
> 1. Looking at the files here, it looks like the License should be:
> ASL 1.1 and GPLv2+
> The ant parts seem to be under the ASL1.1, and the rest is GPLv2 or later.
> Unless there is something I am missing there... 
Of course, you are right.
http://cobertura.sourceforge.net/license.html 
I've admired by the juridical/technical trick of copyright holder, and forgot about my first wrong assumption. Now, it is corrected.

BTW I hope, the spec file won't be considered as a thing that links software with incompatible licenses. See here:
http://cobertura.svn.sourceforge.net/viewvc/cobertura/trunk/cobertura/src/net/sourceforge/cobertura/ant/package.html?view=markup

The second release is prepared for review:
Spec URL: http://victorv.fedorapeople.org/files/cobertura.spec
SRPM URL: http://victorv.fedorapeople.org/files/cobertura-1.9-2.fc12.src.rpm

Changes:
* The license tag is changed

The rpmlint tool shows 0 errors, 0 warnings against SRPM and all RPMs.

Comment 4 Kevin Fenzi 2009-08-10 15:31:37 UTC
well, the license makes sense to me. 
If you like we can ask legal to take a quick look at it to be sure?

Hopefully they can do so soon so we can get your feature moving...

Comment 5 Kevin Fenzi 2009-08-12 15:30:11 UTC
Sigh. Put the blocker in the depends on field. ;( 

Fixed now.

Comment 6 Tom "spot" Callaway 2009-08-12 17:58:46 UTC
Yeah, looks okay to me. Lifting FE-Legal.

Comment 7 Kevin Fenzi 2009-08-12 18:04:41 UTC
Excellent. I see no further blockers here, so this package is APPROVED. 
Feel free to request cvs.

Comment 8 Victor G. Vasilyev 2009-08-12 19:40:01 UTC
New Package CVS Request
=======================
Package Name: cobertura
Short Description: Java tool for calculating the test coverage
Owners: victorv
Branches: F-10 F-11
InitialCC:

Comment 9 Kevin Fenzi 2009-08-13 00:02:13 UTC
cvs done.

Comment 10 Victor G. Vasilyev 2009-08-13 00:39:45 UTC
Successful Koji build against the devel branch:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1602409

Comment 11 Mat Booth 2009-08-22 21:27:40 UTC
Hi Victor,

Are you going to build this package for F-11?

Comment 12 Fedora Update System 2009-08-23 01:26:49 UTC
cobertura-1.9-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/cobertura-1.9-3.fc11

Comment 13 Victor G. Vasilyev 2009-08-23 01:36:51 UTC
Hi Mat,

Please, test it and change its karma ( at least in bodhi :-) ).

Comment 14 Mat Booth 2009-08-23 12:39:20 UTC
(In reply to comment #13)
> Hi Mat,
> 
> Please, test it and change its karma ( at least in bodhi :-) ).  

I rated it positively in Bodhi, thanks.

One more question, while I'm here:

Is there any particular reason you packaged this version as opposed to the latest version? I was specifically after creating "summaryXml" format reports, but I see now that option is only available in Cobertura >= 1.9.1

Comment 15 Victor G. Vasilyev 2009-08-23 15:44:21 UTC
(In reply to comment #14)
> Is there any particular reason you packaged this version as opposed to the
> latest version?
There is only one significant reason the version 1.9 was tested together with the NetBeans 6.7.1.

> I was specifically after creating "summaryXml" format reports,
> but I see now that option is only available in Cobertura >= 1.9.1  
You can discuss inclusion of the latest version to the NetBeans here: 
mailto:nbusers@netbeans.org
mailto:users@codecoverage.netbeans.org

I'm sure if the new features of the Cobertura will be valuable for community then the latest version will be used by the NetBeans and the version, of course, will be included in Fedora. Note, we are not far from the NetBeans 6.8.

AFAIU the main point to use "summaryXml" is based on existence of a large project under test. There are many users of the NetBeans who has working on very large projects. You can find support from their side in voting against RFE filed  here: http://www.netbeans.org/issues

Comment 16 Fedora Update System 2009-09-11 23:28:11 UTC
cobertura-1.9-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.