Bug 510283 - "the working directory is not writable"
"the working directory is not writable"
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
11
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 11:09 EDT by Matt Castelein
Modified: 2013-04-30 19:43 EDT (History)
4 users (show)

See Also:
Fixed In Version: 9.6.1-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 17:56:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matt Castelein 2009-07-08 11:09:00 EDT
No matter how many times I change the permissions on the working directory, this message, "the working directory is not writable" keeps coming back.
Comment 1 Matt Castelein 2009-07-08 11:10:33 EDT
Whoops, clicked too quick.. I have:

bind-libs-9.6.1-2.fc11.x86_64
bind-9.6.1-2.fc11.x86_64
bind-chroot-9.6.1-2.fc11.x86_64
bind-utils-9.6.1-2.fc11.x86_64
Comment 2 Adam Tkac 2009-07-13 09:11:01 EDT
Non writable working directory is long time feature on all RH systems (both Fedora and RHEL). There are only two cases in production environment when named needs to write something - secondary zones and/or DDNS zones. There are two writable directories inside /var/named called "slaves" "dynamic" for such purposes.

Only one reason why /var/named should be writable by named process is debugging. I added new option called "DEBUG" to /etc/sysconfig/named. If you set DEBUG=yes then /var/named become writable by named user.
Comment 3 Fedora Update System 2009-07-13 09:16:22 EDT
bind-9.6.1-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/bind-9.6.1-3.fc11
Comment 4 Fedora Update System 2009-07-19 06:09:23 EDT
bind-9.6.1-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bind'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7708
Comment 5 Fedora Update System 2009-07-22 17:56:40 EDT
bind-9.6.1-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Adam Tkac 2010-01-27 08:25:55 EST
The "DEBUG" change caused problems for many users (bug #545128). I have to revert the patch. As I wrote in comment #2 this is actually a feature, not a bug.
Comment 7 John Souvestre 2010-05-07 17:43:20 EDT
I just did an up2date on our name servers.  I'm now running BIND 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.2.  I did not have this problem previously.  Now, every time I reload, this appears in my named.log:

    general: error: the working directory is not writable

My name servers seem to be working OK, but I admit that this makes me nervous.  I'm not trying to write to the working directory, and the message refers to this as an "error".  But you say it is a feature, so I'm somewhat confused.

Is this indeed the same issue being discussed here?  What should I do, if anything?  Thanks.
Comment 8 Adam Tkac 2010-05-10 06:27:33 EDT
(In reply to comment #7)
> I just did an up2date on our name servers.  I'm now running BIND
> 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.2.  I did not have this problem previously. 
> Now, every time I reload, this appears in my named.log:
> 
>     general: error: the working directory is not writable
> 
> My name servers seem to be working OK, but I admit that this makes me nervous. 
> I'm not trying to write to the working directory, and the message refers to
> this as an "error".  But you say it is a feature, so I'm somewhat confused.
> 
> Is this indeed the same issue being discussed here?  What should I do, if
> anything?  Thanks.    

Ignore that warning, you cannot do anything. This message is informational, not an error. If it makes you crazy you can open a bug report against Red Hat Enterprise Linux 5 and ask to mark the message as "info" instead of "error".

Note You need to log in before you can comment on or make changes to this bug.