Bug 510307 - gvim spews messages about gtk_form_set_static_gravity
gvim spews messages about gtk_form_set_static_gravity
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 12:21 EDT by Pete Zaitcev
Modified: 2009-12-21 23:59 EST (History)
9 users (show)

See Also:
Fixed In Version: 7.2.315-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-02 12:28:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2009-07-08 12:21:39 EDT
Description of problem:

The gvim prints the following to the terminal:
** (gvim:6411): CRITICAL **: gtk_form_set_static_gravity: assertion `static_gravity_supported' failed
This interferes with the normal use of terminal.

Version-Release number of selected component (if applicable):

vim-X11-7.2.148-1.fc11.x86_64

How reproducible:

Synchronous

Steps to Reproduce:
1. run gvim
  
Actual results:

Spew

Expected results:

Silence

Additional info:

It is common for GTK people to turn warnings on and off, but this seems
more interesting than the usual ones, so the bug.

The editor seems to work ok despite the message.
Comment 1 Pete Zaitcev 2009-07-31 21:55:02 EDT
Aww, man. This is annoying:
 http://ftp.moblin.org/moblin/releases/test/alpha1/doc/gdk/gdk-Windows.html#gdk-window-set-static-gravities
The doc suggests that our X11 server may not support StaticGravity period.
I have no clue what that means for the child windows.
Comment 2 Pete Zaitcev 2009-08-04 19:38:07 EDT
Kasten, can we just have this assertion commented out? It's not like
its result affects anything. This printout is very annoying.
Comment 3 James Vega 2009-10-14 15:35:51 EDT
That's essentially what upstream patch 7.2.257 does.
http://ftp.vim.org/pub/vim/patches/7.2/7.2.257
Comment 4 Bug Zapper 2009-11-16 05:45:14 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Hollis Blanchard 2009-11-24 20:43:42 EST
Bug is still present, and it looks like an easy fix (already committed upstream). Can we get an update for F12?
Comment 6 Karsten Hopp 2009-12-02 12:28:29 EST
I'm preparing an update with this fix.
Comment 7 Fedora Update System 2009-12-03 09:29:05 EST
vim-7.2.315-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/vim-7.2.315-1.fc12
Comment 8 Fedora Update System 2009-12-03 09:29:44 EST
vim-7.2.315-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/vim-7.2.315-1.fc11
Comment 9 Fedora Update System 2009-12-03 09:30:22 EST
vim-7.2.315-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/vim-7.2.315-1.fc10
Comment 10 Fedora Update System 2009-12-21 23:43:16 EST
vim-7.2.315-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2009-12-21 23:59:00 EST
vim-7.2.315-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.