Bug 51031 - first reboot locks at USB init
first reboot locks at USB init
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-06 14:54 EDT by Steve Bonneville
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-27 14:06:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Bonneville 2001-08-06 14:54:53 EDT
Description of Problem:

On first reboot after installation, system locks at
"Initializing USB controller (usb-uhci):" (no OK or
FAILED or anything).  Power cycling the system and
rebooting succeeds in booting the box, no problems
are observed.

System is a Dell Latitude C600 laptop.  /boot is ext2 
on /dev/hda6, / is ext3 on /dev/hda10, both were
reformatted in installation process.  "Everything"
install.
Comment 1 Bill Nottingham 2001-08-06 14:59:37 EDT
Assigning to kernel.
Comment 2 Glen Foster 2001-08-06 18:27:41 EDT
This defect is considered SHOULD-FIX for Fairfax.
Comment 3 Pete Zaitcev 2001-08-07 22:58:32 EDT
The bug seems not reproducible, but I do not want
to give up that easily. I'd like the requestor
to take SysRq-P next time it hangs (hopefuly it was
not a hard lock).

Hot key is documented here:
/usr/src/linux/Documentation/sysrq.txt

Sysctl ought to be enabled:
In /etc/sysctl.conf, line "kernel.sysrq = 1".
Comment 4 Steve Bonneville 2001-08-08 12:16:41 EDT
Hm. I just tried this again and couldn't reproduce the problem either.
I reinstalled the machine identically, formatted both partitions again, the
whole nine yards.  The only differences: I used CDROMs burned from ISO 
images rather than an NFS install from porkchop, and I made the change
to /etc/sysctl.conf to enable SysRq from the installer's tty2 before I
booted the new installation for the first time.  To be painfully clear, 
I didn't see the problem or take SysRq-P.

Dunno.  I *saw* this on my first installs of beta2 and beta3.  <shrug>
Comment 5 Pete Zaitcev 2001-08-08 12:48:40 EDT
Yes, like I said - a nasty bug. If it oosed we'd have
at least some material for investigation. :(
Comment 6 Steve Bonneville 2001-08-20 18:18:46 EDT
Another data point.  I just did a NFS reinstall with Roswell2 and had the
same lockup.  Again, after "Initializing USB controller (usb-uhci):"; the
cursor was flashing just after the colon on the line.  Didn't have SysRq
enabled, of course.  :(  Booted fine after power cycle.  If I get the time,
I'll try doing some kickstarts with SysRq on in %post and see if I can 
trip this.
Comment 7 Steve Bonneville 2001-09-19 16:08:41 EDT
Observed this bug again with Enigma (2.4.7-10).  Summary:
  * The machine froze again at the first boot after install at the same place.
    I've seen this reproduced each time I've done the first install using NFS
    and a bootnet.img floppy.
  * I set SysRq on during the install this time.  Tried it after lockup, but
    got no response from the system.
  * After power cycle / reboot, system booted fine.  SysRq worked, so it was
    a hard lock in the previous step.
  * I was able to reproduce the bug this time.  I performed a second fresh
    re-install (bootnet.img/NFS) and got the hard lock at the same spot in
    the first boot sequence after installation.  No response from SysRq. 
    Again, the system booted fine after a power cycle, and subsequent boots
    also succeeded.
Comment 8 Pete Zaitcev 2002-05-28 16:04:09 EDT
Does RHL 7.3 work?
Comment 9 Pete Zaitcev 2003-02-27 14:06:58 EST
Apparently, bug staled out? Closing.


Note You need to log in before you can comment on or make changes to this bug.