Bug 510313 - [PATCH] Detect missing ruby(abi) Require in rubygem- packages
[PATCH] Detect missing ruby(abi) Require in rubygem- packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 12:54 EDT by Lubomir Rintel
Modified: 2014-05-09 09:25 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-09 09:25:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Detect missing ruby(abi) Require in rubygem- packages (2.15 KB, text/plain)
2009-07-08 12:55 EDT, Lubomir Rintel
no flags Details
Proposed fix (2.75 KB, text/plain)
2010-02-08 10:01 EST, Lubomir Rintel
no flags Details

  None (edit)
Description Lubomir Rintel 2009-07-08 12:54:53 EDT
This is mandated by Ruby guidelines [1]. No idea if this (ruby(abi) or
rubygem- packages) is Fedora specific, but I found no way of differentiating
it as such.

[1] https://fedoraproject.org/wiki/Packaging:Ruby

Filing the bug here, since the upstream bug tracker returns internal errors upon attempts to create a ticket.
Comment 1 Lubomir Rintel 2009-07-08 12:55:27 EDT
Created attachment 350967 [details]
Detect missing ruby(abi) Require in rubygem- packages
Comment 2 Ville Skyttä 2009-07-09 17:09:31 EDT
I think this is Fedora specific.  On first sight the patch looks good, I'll take a closer look a bit later, but I really think stuff like this should be automated for ruby stuff in rpm(-build), see for example how is done for python packages (/usr/lib/rpm/pythondeps.sh).
Comment 3 Bug Zapper 2009-11-16 05:45:20 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Ville Skyttä 2010-01-31 17:12:28 EST
Any news about getting the ruby abi dependencies automated (comment 2)?
Comment 5 Lubomir Rintel 2010-02-08 10:01:10 EST
Created attachment 389535 [details]
Proposed fix

(In reply to comment #4)
> Any news about getting the ruby abi dependencies automated (comment 2)?    

Yup. Sorry for the delay.

I have crafted some patch (see attachment) but did not try it out yet, since it did not seem straightforward on a non-rawhide system. Will try to give it a try later today and eventually submit upstreamwards.

To yield sensible results, libmagic needs to be patched with bug #562840 patch.
Comment 6 Lubomir Rintel 2010-02-08 10:06:49 EST
http://koji.fedoraproject.org/koji/taskinfo?taskID=1964777
http://koji.fedoraproject.org/koji/taskinfo?taskID=1964772

I hope these won't expire until I try them :)
Comment 7 Lubomir Rintel 2010-03-18 15:57:10 EDT
Opened an upstream ticket here, reassigning to RPM.
http://rpm.org/ticket/151

Panu: Would it be possible to get this into f13?
Comment 8 Panu Matilainen 2010-03-19 02:40:12 EDT
Adding new dependancy generators to F13 at this would be highly inappropriate, as new builds would start requiring things that nothing provides. That's what rawhide is for: plan how to go about it (mass-rebuilds for ruby packages needed)
Comment 9 Panu Matilainen 2011-01-31 08:25:58 EST
Actually now that it's possible in rpm >= 4.9.0, I'd suggest you add the necessary bits into ruby package itself. That way the ruby people are in charge of their own dependencies, can enhance + fix things without needing to wait for rpm to get patched, and we dont need to worry about dragging new dependencies into rpm-build.

"Official documentation" is non-existent at the moment but there are examples in python-cups package, rpm's internal dependency generators (some of which might be moving out of rpm proper in the future) and the basics for adding similar thing for gfortran are outlined here http://lists.fedoraproject.org/pipermail/packaging/2011-January/007598.html.
Comment 10 Vít Ondruch 2014-05-09 09:25:40 EDT
Ruby 2.1 ships with generators for rubygems- packages. Since it is majority of Ruby packages and preferred form of packaging Ruby stuff, I think we can close this now.

Note You need to log in before you can comment on or make changes to this bug.