Bug 510315 - xulrunner-1.9.1-1.fc11 breaks firefox-3.5-0.20.beta4.fc11.i586
xulrunner-1.9.1-1.fc11 breaks firefox-3.5-0.20.beta4.fc11.i586
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 13:03 EDT by Gregory Lee Bartholomew
Modified: 2009-07-08 15:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-08 14:38:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregory Lee Bartholomew 2009-07-08 13:03:17 EDT
Description of problem:

xulrunner-1.9.1-1.fc11 breaks firefox-3.5-0.20.beta4.fc11.i586

Version-Release number of selected component (if applicable):

Given in description.

How reproducible:

Not sure. This bug at least breaks firefox for those of us who run the 32-bit browser on x86_64 systems (I do this for to use Sun's 32-bit java plugin because the java that comes with Fedora seems to crash while playing java chess applets on games.yahoo.com (I should probably file a bug report for that somewhere as well)).

Steps to Reproduce:
1. Have Fedora configured with 32-bit Firefox like so:

[user@gigabyte ~]$ cat /etc/yum.repos.d/my-fedora.repo /etc/yum.repos.d/my-fedora-updates.repo 
[my-fedora]
name=My Fedora $releasever - $basearch
baseurl=http://mirror.cs.siue.edu/fedora/$releasever/os/$basearch/
enabled=1
gpgcheck=0

[my-fedora-i586]
name=My Fedora $releasever - i586
baseurl=http://mirror.cs.siue.edu/fedora/$releasever/os/i586/
enabled=1
gpgcheck=0
includepkgs=firefox

[my-updates]
name=My Fedora $releasever - $basearch - Updates
baseurl=http://mirror.cs.siue.edu/fedora/$releasever/updates/$basearch/
enabled=1
gpgcheck=0

[my-updates-i586]
name=My Fedora $releasever - i586 - Updates
baseurl=http://mirror.cs.siue.edu/fedora/$releasever/updates/i586/
enabled=1
gpgcheck=0
includepkgs=firefox

2. Update system via "yum update".
  
Actual results:

[user@gigabyte ~]$ firefox 
Could not find compatible GRE between version 1.9.1b4 and 1.9.1b4.

momentary "hour glass" cursor but no window opens

Expected results:

Firefox should start

Additional info:

Downgrading xulrunner fixed the problem:

[root@gigabyte ~]# yum downgrade xulrunner
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Downgrade Process
Reducing My Fedora 11 - i586 to included packages only
Finished
Reducing My Fedora 11 - i586 - Updates to included packages only
Finished
Resolving Dependencies
--> Running transaction check
---> Package xulrunner.i586 0:1.9.1-0.20.beta4.fc11 set to be updated
---> Package xulrunner.x86_64 0:1.9.1-0.20.beta4.fc11 set to be updated
---> Package xulrunner.i586 0:1.9.1-1.fc11 set to be erased
---> Package xulrunner.x86_64 0:1.9.1-1.fc11 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================================================================
 Package                                  Arch                                  Version                                              Repository                                Size
====================================================================================================================================================================================
Installing:
 xulrunner                                i586                                  1.9.1-0.20.beta4.fc11                                my-fedora                                 10 M
 xulrunner                                x86_64                                1.9.1-0.20.beta4.fc11                                my-fedora                                9.5 M
Removing:
 xulrunner                                i586                                  1.9.1-1.fc11                                         installed                                 24 M
 xulrunner                                x86_64                                1.9.1-1.fc11                                         installed                                 25 M

Transaction Summary
====================================================================================================================================================================================
Install      2 Package(s)         
Update       0 Package(s)         
Remove       2 Package(s)         

Total download size: 19 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): xulrunner-1.9.1-0.20.beta4.fc11.i586.rpm                                                                                                              |  10 MB     00:00     
(2/2): xulrunner-1.9.1-0.20.beta4.fc11.x86_64.rpm                                                                                                            | 9.5 MB     00:00     
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                               9.8 MB/s |  19 MB     00:01     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : xulrunner-1.9.1-0.20.beta4.fc11.x86_64                                                                                                                       1/4 
  Installing     : xulrunner-1.9.1-0.20.beta4.fc11.i586                                                                                                                         2/4 
  Cleanup        : xulrunner-1.9.1-1.fc11                                                                                                                                       3/4 
  Cleanup        : xulrunner-1.9.1-1.fc11                                                                                                                                       4/4 

Removed:
  xulrunner.i586 0:1.9.1-1.fc11                                                           xulrunner.x86_64 0:1.9.1-1.fc11                                                          

Installed:
  xulrunner.i586 0:1.9.1-0.20.beta4.fc11                                                  xulrunner.x86_64 0:1.9.1-0.20.beta4.fc11                                                 

Complete!
[root@gigabyte ~]#
Comment 1 Christopher Aillon 2009-07-08 14:38:33 EDT
It seems your mirror was in a broken state, for some reason.  You need firefox and xulrunner to ugprade at the same time.  When updating firefox, it forces a version upgrade to the correct version of xulrunner.  There was a bug that when you update xulrunner, it did not force a version upgrade of firefox if it was installed.  That is fixed now, but you need to get both a newer firefox and xulrunner combo to see the fruits of that.

In summary, this is not a bug that we can solve.  Simply wait until your mirror has updated its firefox.  Since xulrunner-1.9.1-1.fc11 and firefox-3.5-1.fc11 were released simultaneously, I am unsure why your mirror would not have both.  But when it does, your yum upgrade command will pick up both and you will be fine the rest of the way.
Comment 2 Gregory Lee Bartholomew 2009-07-08 15:24:52 EDT
Yep, that was the problem.  How embarrassing, I had an "i586" in my rsync scripts where I meant to have an "i386".  As a tangentially related issue/feature request, perhaps the folder name in the mirrors should be changed to i586 to agree with the package names that are in them.

Thanks

Note You need to log in before you can comment on or make changes to this bug.