Bug 510318 - (EE) intel(0): [drm] Failed to detect GEM. Kernel 2.6.28 required.
(EE) intel(0): [drm] Failed to detect GEM. Kernel 2.6.28 required.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 13:12 EDT by Pat Kane
Modified: 2009-07-11 09:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-08 15:31:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (9.69 KB, text/plain)
2009-07-08 13:12 EDT, Pat Kane
no flags Details

  None (edit)
Description Pat Kane 2009-07-08 13:12:41 EDT
Created attachment 350969 [details]
Xorg log file

Description of problem:
Xorg does not start on recent RawHide on box with intel 82865G

Version-Release number of selected component (if applicable):
X.Org X Server 1.6.99.1
Release Date: (unreleased)
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-128.1.14.el5 i686 
Current Operating System: Linux qed 2.6.31-0.42.rc2.fc12.i686.PAE #1 SMP Sat Jul 4 20:49:14 EDT 2009 i686
Kernel command line: ro root=/dev/mapper/vg_qed-lv_root 
Build Date: 06 July 2009  02:07:54AM
Build ID: xorg-x11-server 1.6.99-9.20090706.fc12 
...
(--) PCI:*(0:0:2:0) 8086:2572:1028:01d5 Intel Corporation 82865G Integrated Graphics Controller rev 2, Mem @ 0xe8000000/134217728, 0xfeb80000/524288, I/O @ 0x0000ed98/8, BIOS @ 0x????????/131072
...


 
How reproducible:

Steps to Reproduce:
1.  yum upgrade to rawhide
2.  Xorg
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Jackson 2009-07-08 15:31:11 EDT
Hah, yeah, we disabled gem on 8xx because it didn't work that well, but now the intel driver requires it.

kernel 2.6.31-0.56 and later have gem enabled for 8xx again.  Which isn't to say it'll work, but it'll at least fail differently.
Comment 2 Pat Kane 2009-07-11 09:58:24 EDT
Today's update to 2.6.31-0.62.rc2.git4.fc12.i686.PAE has fixed 
the problem.  Emacs screen updates are slow, but at the screen
is not scrozzed like it was two updates ago.

Note You need to log in before you can comment on or make changes to this bug.