Bug 51032 - grubs idea of "relative" paths is confusing
Summary: grubs idea of "relative" paths is confusing
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: grub   
(Show other bugs)
Version: roswell
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-06 18:56 UTC by Adrian Likins
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 22:41:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adrian Likins 2001-08-06 18:56:07 UTC
Description of Problem:


How Reproducible:


Steps to Reproduce:
1. edit /boot/grub/grub.config to include a initrd, set its path to say
"/boot/fooo.img"

2. reboot, and it fails of course

Actual Results:

I initially used a "absolute" path, which is incorrect.

However, the use of relative paths in this case is a bit odd, in
my opinion. The comment in the default grub.conf of:

# NOTICE:  You have a /boot partition.  This means that
#          all kernel paths are relative to /boot/


Doesnt really help any. Since grub wants the path name in
the form "/initrd-foo.img". Which seems like an absolute
path to me (paths starting with / are generally absolute
paths to my brain...)

If you ignore that bit, the path still works out mentally
as /boot//initrd-foo.img, which while valid, is a bit strange. 

I suspect changing this odd behaviour in grub is painful,
so a better comment wouldnt hurt (with example?). Some info
in the grub interactive editing screen wouldnt hurt either.

Expected Results:


Additional Information:

Comment 1 Glen Foster 2001-08-06 22:02:29 UTC
Adding a more descriptive comment would be a good thing.

Comment 2 Glen Foster 2001-08-06 22:40:55 UTC
We (Red Hat) should try to fix this for the next release.

Comment 3 Jeremy Katz 2001-08-07 03:05:11 UTC
Ask and ye shall receive...  added an example stanza for both cases (having a
/boot and not having a /boot) commented out at the top with an initrd line.


Note You need to log in before you can comment on or make changes to this bug.