Bug 510320 - gvim lost all selections
gvim lost all selections
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 13:20 EDT by Pete Zaitcev
Modified: 2009-07-11 13:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-10 22:23:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2009-07-08 13:20:55 EDT
Description of problem:

Apparently gvim cannot communicate with any selections properly anymore
(cannot import them or create them).

Version-Release number of selected component (if applicable):

vim-X11-7.2.148-1.fc11.x86_64  <===== not changed since F11!

Components changed today:
libX11-1.2.1-3.fc12.x86_64
glib2-2.21.3-1.fc12.x86_64 --- unlikely, but...
gtk2-2.17.3-1.fc12.x86_64

xorg-x11-server-Xorg was updated too, but I ran over TCP to a different
display, same story. So that's not it.

How reproducible:

100%

Steps to Reproduce:
1. open gvim
2. create a selection CLIPBOARD somewhere else
3. optional: verify with  xclip -o -selection clipboard
4. go back to gvim and do "+p
  
Actual results:

No paste

Expected results:

Paste

Additional info:

Forget complains about the "CRITICAL **: gtk_form_set_static_gravity:
assertion `static_gravity_supported' failed". This one is a bit problem,
virtually makes gvim useless.
Comment 1 Matthias Clasen 2009-07-08 16:50:26 EDT
Interesting. Sounds like client-side window fallout.
Filed here: http://bugzilla.gnome.org/show_bug.cgi?id=588115
Comment 2 Pete Zaitcev 2009-07-08 17:44:54 EDT
If you want to close this and track upstram it's fine, I have account.
Comment 3 Matthias Clasen 2009-07-10 22:23:27 EDT
Should be fixed in 2.17.4
Comment 4 Pete Zaitcev 2009-07-11 13:37:24 EDT
Confirmed fixed (I downloaded gtk2-2.17.4-1.fc12.x86_64 from Koji).

Note You need to log in before you can comment on or make changes to this bug.