Bug 510359 - Man pages under /usr/share/man/sv: Add directories to man package or is "sv" a broken locale?
Man pages under /usr/share/man/sv: Add directories to man package or is "sv" ...
Status: CLOSED DUPLICATE of bug 220265
Product: Fedora
Classification: Fedora
Component: fakeroot (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 220265
  Show dependency treegraph
 
Reported: 2009-07-08 15:39 EDT by Dennis Gregorovic
Modified: 2009-07-31 13:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-27 15:33:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gregorovic 2009-07-08 15:39:03 EDT
Description of problem:
The following directories are used by fakeroot but unowned by any package:
  Unowned Directory: /usr/share/man/sv
  Unowned Directory: /usr/share/man/sv/man1


Version-Release number of selected component (if applicable):
fakeroot-1.12.2-21.fc11
Comment 1 Axel Thimm 2009-07-25 09:13:47 EDT
Looks like there are more packages using /usr/share/man/sv

# rpm -qf /usr/share/man/sv/*/*|sort -u
dcraw-8.91-1.fc11.x86_64
fakeroot-1.12.2-21.fc11.x86_64
jwhois-4.0-13.fc11.x86_64
shadow-utils-4.1.2-13.fc11.x86_64

It should probably be fixed in the man package (if "sv" is a valid man locale), since even shadow-utils dumps man pages there.
Comment 2 Ivana Varekova 2009-07-27 09:38:38 EDT
This problem have to be fixed on the fakeroot side - man package could not contain all locale directories. (The tread about this issue is on:
https://bugzilla.redhat.com/show_bug.cgi?id=220265 )
Comment 3 Axel Thimm 2009-07-27 15:33:03 EDT
(In reply to comment #2)
> This problem have to be fixed on the fakeroot side - man package could not
> contain all locale directories. (The tread about this issue is on:
> https://bugzilla.redhat.com/show_bug.cgi?id=220265 )  

Why not? I answered on the quoted thread and I think it is better to fix this bug at one place than at several dozens of packages.

*** This bug has been marked as a duplicate of bug 220265 ***
Comment 4 Axel Thimm 2009-07-27 15:53:51 EDT
(In reply to comment #3)
> than at several dozens of packages.

Correction to self, these are dozens of locales, but just 9 client packages. Still the solution is unclean and will break once one locale is suddenly supported by man.

Note You need to log in before you can comment on or make changes to this bug.