This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 510370 - Add into Hardware and/or OS rquirements for Satellite Guide a note about supported hardware platforms
Add into Hardware and/or OS rquirements for Satellite Guide a note about supp...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs Installation Guide (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: John Ha
Brad Buckingham
: Documentation
Depends On:
Blocks: 456984
  Show dependency treegraph
 
Reported: 2009-07-08 16:01 EDT by Clifford Perry
Modified: 2014-08-04 18:18 EDT (History)
5 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:45:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clifford Perry 2009-07-08 16:01:45 EDT
Description of problem:

Right now, we make no mention of s390, s390x, x86_64 and i386 Archs. Nor do we state VMWare and Xen/KVM are valid platfroms. 

It would be great if we added this into the Satellite Guide, maybe a quick Matrix 
        i386 x86_64 s390 s390x Xen KVM VMWare
RHEL 4    X    X     X    X     -   -    X

RHEL 5    X    X     -    X     X   X    X

Pretty sure needs some fleshing out, but get right idea. 

Cliff


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Brandon Perkins 2009-07-08 16:55:47 EDT
The matrix is a bit confusing for me.  I'm guessing the context is for server-side support (if that is an incorrect assumption, then I'm going to have many more comments).  So here are my comments:

For i386, x86_64, s390, and s390x WRT RHEL 4 and 5, its all fine.

For Xen, KVM, and VMware it is unclear as to hosts and guests.  It would appear that we're talking about the host and taking the guest out of the mix and assuming the architecture itself is what's going on.  If that assumption is correct, then:

Xen is correct.
KVM is wrong (we do not support Satellite running under a KVM guest).
VMware is wrong as it is not RHEL 4 or RHEL 5, its ESX 3.5.

If, however its the other way where we are talking about guests, then:

Xen is wrong and should include RHEL 4
KVM is still wrong as we still do not support Satellite running under a KVM guest.
VMware is correct.

So, knowing the context here would help a lot in determining what the text should be.
Comment 2 Todd Sanders 2009-07-08 22:07:09 EDT
Here are the mainframe specs as provided by Brad Hinson:

Minimum requirements:
--------------------

1 IFL, either in LPAR configuration or shared through z/VM
1 GB storage (memory)
1 GB swap on ECKD DASD
1xMod3 ECKD DASD or >= 2 GB FCP SCSI LUN for OS install
Estimated 12 GB disk space for embedded database
Estimated 6 GB disk space per channel



Recommended configuration:
-------------------------

2+ IFLs on z9 or earlier, 1+ IFL on z10
2 GB storage (memory)
512 MB swap on VDISK + 1 GB swap on ECKD DASD
1xMod9 ECKD DASD or >= 2 GB *multipathed* FCP SCSI LUN for OS install
Estimated 12 GB disk space for embedded database
Estimated 6 GB disk space per channel
z/VM 5.3 or later [1]
VSWITCH or Hipersocket LAN for high speed connections to guests



[1] z/VM required for kickstart/provisioning of guests
Comment 4 John Ha 2009-07-09 16:55:10 EDT
Here are the Hardware Requirements as they exist right now:

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5.3.0/html/Installation_Guide/s1-requirements-hardware.html

So, since we are also looking at changing the recommendations for Ram for x86_64, should we also look at the Processor requirements as well? The minimum required proc is a Pentium IV 2.4 GHz. Since they're now moved on to their Core(TM) line of processors, should we amend that to say "Intel Core processor 2.4GHz, 512k cache or equivalent" for the Required processor. Then change the "Recommended" processor to "Intel Core 2 dual-core processor, 512k cache or equivalent"?

As for the s/390 specs, I was thinking of separating the two arches into separate sections: One called "Hardware Requirements -- x86 and x86_64" and the other "Hardware Requirements -- s/390". They'll both have similar table in each section for embedded and standalone DB as in the link above.
Comment 5 Clifford Perry 2009-07-10 09:12:19 EDT
John - this sounds OK to me. 

Thanks,
Cliff
Comment 6 John Ha 2009-07-10 16:16:23 EDT
Okay, I've fixed all the issues discussed in a newly built revised version of this hardware requirements section:

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5.3.0/html/Installation_Guide/s1-requirements-hardware.html

Click through to the next subsection for the s390 table.

Let me know of any changes or suggestions and I'll implement them straight away.
Comment 7 Clifford Perry 2009-07-13 12:20:33 EDT
Reads good to me, I am happy with this to proceed. Please make sure you give yupdated docs to Jesus this week ASAP. Thanks

Cliff
Comment 8 Brad Buckingham 2009-07-15 11:50:01 EDT
Moving to ON_QA.  Latest guides (rhn-i18n-guides-5.3.0.9-1.el[45]sat) included in the 20090714 ISO.
Comment 9 Brad Buckingham 2009-07-15 13:59:35 EDT
Verified changes to the installation guide using
Satellite-5.3.0-RHEL4-re20090714.0-i386-embedded-oracle.iso.  Changes correspond to the details in #4 & #6.
Comment 10 John Matthews 2009-08-20 09:28:49 EDT
RELEASE_PENDING, verified against rhndev1.z900 reg to stage.
Using comments #4 and #6 to verify.
Comment 11 Brandon Perkins 2009-09-10 16:45:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.