Bug 510384 - kernel link is not produce proper results for _end symbol
kernel link is not produce proper results for _end symbol
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
11
powerpc Linux
low Severity medium
: ---
: ---
Assigned To: Nick Clifton
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 17:44 EDT by Kumar Gala
Modified: 2009-08-12 16:55 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.19.51.0.14-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-17 07:20:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kumar Gala 2009-07-08 17:44:39 EDT
The _end symbol in a kernel build is not correct.  When building the 'mpc85xx_defconfig' on a v2.6.30 kernel the _end symbol is:

vmlinux:00001000 A _end

Building this same kernel w/gcc4.3 & binutils 2.18.50.0.9-8.fc10 from FC10 produce:

vmlinux:c0599000 A _end

It appears to be some issue with the ALIGN() directive in the linker script (arch/powerpc/kernel/vmlinux.lds) before the _end.  If we remove the ALIGN directive the _end symbol has a reasonable value of:

vmlinux:c05d3018 A _end
Comment 1 Nick Clifton 2009-07-10 05:21:15 EDT
Hi Kumar,

  I assume that this problem is the same as the one that you have reported on the bug-binutils mailing list:

  http://lists.gnu.org/archive/html/bug-binutils/2009-07/msg00059.h

It sounds like you have found a workaround for the problem.  Do you still want this bug report left open ?

Cheers
  Nick
Comment 2 Kumar Gala 2009-07-10 10:53:29 EDT
Yes I'd like it still open.  While we have a workaround I dont consider it sufficient since the fact that we have a chicken/egg scenario here.

Older kernel linker scripts aren't going to know about all sections and thus have orphans.  If newer binutils are going to place orphan sections at places that break things like _end we have an issue.
Comment 3 Nick Clifton 2009-07-10 13:56:38 EDT
Hi Kumar,

  In which case, please could you put together a small testcase that reproduces the problem so that I can investigate further.

Cheers
  Nick
Comment 4 Kumar Gala 2009-07-11 12:45:11 EDT
It looks like Alan Morda posted a patch and has applied it to mainline binutils CVS for this issue.

Do you mind back porting that to the fedora binutils and making a bug fix release

The commit info is here:

http://sourceware.org/ml/binutils-cvs/2009-07/msg00069.html
Comment 5 Nick Clifton 2009-07-14 06:01:53 EDT
Hi Kumar,

> Do you mind back porting that to the fedora binutils and making a bug fix
> release ?

Done.  binutils-2_19_51_0_11-26_fc12.

Cheers
  Nick
Comment 6 Kumar Gala 2009-07-14 10:27:45 EDT
Thanks.  Any ability to get an updated package for fc11?

- k
Comment 7 Kumar Gala 2009-07-14 10:37:46 EDT
At Josh Boyer's recommendation I'm reopening this and pointing out that it was against F11.
Comment 8 Fedora Update System 2009-07-17 07:19:00 EDT
binutils-2.19.51.0.2-18.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/binutils-2.19.51.0.2-18.fc11
Comment 9 Nick Clifton 2009-07-17 07:20:37 EDT
Hi Kumar,

> Any ability to get an updated package for fc11?

Done.  Update to binutils-2.19.51.0.2.18.fc11.

Cheers
  Nick
Comment 10 Fedora Update System 2009-07-27 07:09:24 EDT
binutils-2.19.51.0.14-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/binutils-2.19.51.0.14-1.fc11
Comment 11 Fedora Update System 2009-08-12 16:55:02 EDT
binutils-2.19.51.0.14-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.