Bug 510412 - Cannot change system language back to English after changing it to Korean.
Summary: Cannot change system language back to English after changing it to Korean.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-language
Version: 11
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Pravin Satpute
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-07-09 07:02 UTC by cal.mcpherson
Modified: 2014-03-26 04:38 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-07-14 04:00:35 UTC


Attachments (Terms of Use)

Description cal.mcpherson 2009-07-09 07:02:53 UTC
Description of problem: Cannot reset system language back to original selection.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Start with an English(US) language install of Gnome Fedora 11
2. Change system language through GUI to Korean.
3. Reboot.
4. Log in, the system language is korean.
5. Change system language through GUI to English(US)
6. Reboot.
7. Log in, the system language is korean.
  
Actual results:
Cannot change back to English language, either via GNOME desktop GUI or system-config-language from terminal, ie desktop is unusable, I don't speak Korean!.

Expected results:
Can change back to English language.

Additional info: the dialog when changing the lanugage indicates log out/in is sufficient for initial language change.  Wrong.  Reboot was required.  Not important though.

Comment 1 Pravin Satpute 2009-07-09 07:54:00 UTC
hmm, i will change it to reboot instead of logout

i think your gdm setting is overriding system-config-languages setting, just check what is selected in GDM lang menu before login

Comment 2 cal.mcpherson 2009-07-10 07:48:50 UTC
I fixed this by editing /home/<myusername>/.dmrc and changing Language=en_USE.UTF-8.  Interestingly, I have 2 users in the system and the other user is now English too.  I thought .dmrc is a per-user locale setting?  

Anyway,  the point is changing the system language setting modified .dmrc from English to Korean the 1st time.  The next time I ran it, it did not modify the .dmrc settings back to English.

In other words, the Language Selection dialog has a bug in it.  Not sure if this is a Gnome project dialog or a Fedora one.

Anyway, I'm happy now I have my default language choice back.  

Thanks.
Cal

Comment 3 Pravin Satpute 2009-07-10 08:56:25 UTC
(In reply to comment #2)
> I fixed this by editing /home/<myusername>/.dmrc and changing
> Language=en_USE.UTF-8.  Interestingly, I have 2 users in the system and the
> other user is now English too.  I thought .dmrc is a per-user locale setting? 
yeah, .dmrc is for local user only
selected language in GDM Menu gets written into that file while login 
 
> 
> Anyway,  the point is changing the system language setting modified .dmrc from
> English to Korean the 1st time.  The next time I ran it, it did not modify the
> .dmrc settings back to English.
> 
> In other words, the Language Selection dialog has a bug in it.  Not sure if
> this is a Gnome project dialog or a Fedora one.

system-config-langauge is used for changing system wide language configuration, It not deals with local user .dmrc but /etc/sysconfig/i18n file

> 
> Anyway, I'm happy now I have my default language choice back.

Congrats!!

Comment 4 Pravin Satpute 2009-07-14 04:01:26 UTC
closing for now
reopen if any problem

Comment 5 Alexander 2009-09-06 06:58:40 UTC
I had the same problem with russian language. It should be possible to change language from system->administration->language without manually editing .dmrc file. For users who do not know what .dmrc file is it is impossible to change language back to english now.

Comment 6 Pravin Satpute 2009-09-07 04:31:57 UTC
yeah, just need to select required language in gdm lang. menu while login, that changes will automatically reflect in .dmrc file

Comment 7 Tomeu Vizoso 2009-09-22 14:42:15 UTC
(In reply to comment #6)
> yeah, just need to select required language in gdm lang. menu while login, that
> changes will automatically reflect in .dmrc file  

Not working here, I had set the language to spanish for testing and even if I select english in the gdm menu it starts up always in spanish.

The English option in the menu is in italics, could be a hint?

Comment 8 Minnikhanov 2010-07-28 10:54:56 UTC
I had the same problem with russian language.
I try to edit /home/ - no result.
Change  to en_US.UTF-8, but after logout /home/<myusername>/.dmrc reseted to Language=ru_RU.UTF-8.

Now I change in /var/cache/gdm/<myusername>/dmrc, and now I have all in English.

My system F12, permanent updated.

Comment 9 Minnikhanov 2010-07-28 11:01:47 UTC
I had the same problem with russian language.
I try to edit /home/<myusername>/.dmrc - no result.
Change ru_RU.UTF-8 to en_US.UTF-8, but after logout/logout-reboot /home/<myusername>/.dmrc reseted to Language=ru_RU.UTF-8.

Now I change in /var/cache/gdm/<myusername>/dmrc, and return to English.

My system F12 x86_64, permanent updated.

Comment 10 Pravin Satpute 2010-07-28 11:21:40 UTC
aha, that's interesting
dunno, it should not happen actually in that way
but looks like cache is updating or getting used by /home/<myusername>/.dmrc

in my opinion actually /home/username/.dmrc should modify cache

Comment 11 fujiwara 2010-07-29 01:08:30 UTC
(In reply to comment #9)
> Now I change in /var/cache/gdm/<myusername>/dmrc, and return to English.

Yes, it's known and under the discussion in upstream bug.
Currently you need to modify the file in the cache dir.
It was implemented for dynamic home dir of anonymous users AFAIK.

Comment 12 Gökhan Sever 2011-03-05 21:40:03 UTC
Same thing happens first switching to Turkish then trying to revert back to English.

Editing tr_TR.UTF-8 to en_US.UTF-8 (in /home/<myusername>/.dmrc), and reboot fixes the issue.

Comment 13 carol 2014-03-26 04:34:29 UTC
Our group have two machines have the same problem,The reason is the user changed system language before he login the machine,if he/she chose chinese then the system language would be zh_SG.UTF-8 and vice-versa,Default is english.

Comment 14 Parag Nemade 2014-03-26 04:38:13 UTC
carol,
   Please file a new bug with all the details like which Fedora version 19 or 20 are you using? what is the system-config-language version installed on your system?


Note You need to log in before you can comment on or make changes to this bug.