Bug 510414 - smaller standard installation
smaller standard installation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-desktop (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-09 03:31 EDT by Ronny Fischer
Modified: 2009-07-19 00:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-19 00:04:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronny Fischer 2009-07-09 03:31:13 EDT
Description of problem:

This is actually a feature request for future versions of Fedora.

It would be very nice if it's possible to make the standard installation small or at least smaller then now. Since some time the packages in a standard installation become more and more, even if they aren't needed. That results in the fact that more resources are used. For example, you won't need bluetooth capabilities installed if you don't have a BT interface.

Actually there is a thread in a forum of the german Fedora community where such things are discussed. In short, there's a wish for more modularization, especially in the big Desktop environments GNOME and KDE. Also necessary might be less dependencies for some components and the change in the fact that Fedora starts much more services at first that obviously are often not needed in systems - this looks like Windows behavior.

For the GNOME and KDE maintainers:

There are distributions that do such things since quiet some time (e.g. Mandriva), I wonder if Fedora is capable to manage that, too.

Version-Release number of selected component (if applicable):

Fedora generally, especially the core applications of KDE and Gnome.

How reproducible:

ever (from one release to to the next)

Steps to Reproduce:
1. Install Fedora 11 for example and compare this to a similar installation of an earlier version (e.g. Fedora 8 or 9) and compare the differences in the amount of the packages.

2. Also compare what you can delete of a standard installation what you want and what you got.

Actual results:

Fedora is getting bigger and bigger every next release. You can observe that pretty nice when performing an upgrade via yum - take a look at the amount of new packages that come to your system just by upgrading.

Expected results:

Fedora should be small in it's basic installation and give the opportunity for the user to choose by himself/herself what is installed.

Additional info:

Basically this feature request means to change the way of what kind of distribution Fedora is. Away from the general purpose system to a small and efficient standard system that is possible to make it an allrounder by yourself - or a very special system if needed.
Comment 1 Yanko Kaneti 2009-07-09 03:48:24 EDT
Sorry to be somewhat abrupt but bright blue future sky ideas are hardly appropriate for bugzilla. Please use a appropriate forum for this, blog about it or use fedora-list. And gnome-desktop is a specific software component, not the Fedora GNOME Desktop as such. 

Work for slimming and somewhat modularising the package collection is constantly done around specific targeted bug reports that are concretely actionable, not just some ideas thrown together. If you have some of those then please take the time to find the appropriate bugizlla component and file away.
Comment 2 Ronny Fischer 2009-07-09 04:13:25 EDT
Sorry to bother you, but a blog is surely not the right place to discuss something like this because responsible persons might not become aware of this and/or will not be interested in like here. Besides that I'm not willing to subsribe to a mailing list for that. And the lack of the correct tag or component for a request like this is obviously not a fault of mine.

What I ask for is to make clear that the actual way of distributing Fedora is far away of being a promising way for the future. Since you stated there is a constant work around for that, why isn't there any concrete result?

I'm sorry but that is no reason to close this request. You better give the opportunity to let others make suggestions, too. I'd like to hear about what other responsible maintainers and packagers think about that. If there would be a specific project page within fedoraproject.org, the discussion about that could be done there.

Regards
Comment 3 Matthias Clasen 2009-07-19 00:04:46 EDT
This has nothing to do with the gnome-desktop package. If you have concrete requests for making things more modular, please file them against the appropriate package. For a general discussion about installation size, I would concur with Yanko that a mailing list is a better forum.

Note You need to log in before you can comment on or make changes to this bug.