Bug 510423 - python bindings are broken
python bindings are broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: csound (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraOnXO
  Show dependency treegraph
 
Reported: 2009-07-09 04:15 EDT by Tomeu Vizoso
Modified: 2009-09-09 23:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: 5.10.1-12.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-09 23:47:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tomeu Vizoso 2009-07-09 04:15:04 EDT
Description of problem:

Cannot import the csound python module

Version-Release number of selected component (if applicable):

csound-python.i586 0:5.10.1-7.fc11

How reproducible:

Always

Steps to Reproduce:
[tomeu@zviratko ~]$ python -c "import csound"
  
Actual results:

Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named csound
[tomeu@zviratko ~]$ python -c "import csnd"
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.6/site-packages/csnd.py", line 25, in <module>
    _csnd = swig_import_helper()
  File "/usr/lib/python2.6/site-packages/csnd.py", line 17, in swig_import_helper
    import _csnd
ImportError: No module named _csnd


Expected results:

No traceback.

Additional info:
Comment 1 Aleksey Lim 2009-07-09 04:28:37 EDT
https://sourceforge.net/tracker/index.php?func=detail&aid=2817271&group_id=81968&atid=564599 relates to `import csnd` issue as well
Comment 2 Peter Robinson 2009-07-09 08:09:59 EDT
I think one of the many patches that need to be added to compile on F11 are broken from when I forward ported them due to either the update to csound 5.10 or python 2.6.

My guess is that its this one if anyone has time to have a look at it
http://cvs.fedoraproject.org/viewvc/rpms/csound/OLPC-2/csound-5.07.0-install-fixes.patch?view=markup
Comment 3 Peter Robinson 2009-07-16 07:34:28 EDT
Please test build

http://koji.fedoraproject.org/koji/taskinfo?taskID=1478646

It has the libcnd.so file built and included but I'm not convinced it properly fixes the issue.
Comment 4 Fedora Update System 2009-07-16 07:40:51 EDT
csound-5.10.1-9.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/csound-5.10.1-9.fc11
Comment 5 Fedora Update System 2009-07-19 06:35:05 EDT
csound-5.10.1-9.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update csound'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7787
Comment 6 Fedora Update System 2009-09-05 10:38:31 EDT
csound-5.10.1-12.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/csound-5.10.1-12.fc11
Comment 7 Fedora Update System 2009-09-06 16:41:40 EDT
csound-5.10.1-12.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update csound'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9349
Comment 8 Fedora Update System 2009-09-09 23:47:49 EDT
csound-5.10.1-12.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.