Bug 510425 - Attach device from xml file failed on KVM
Attach device from xml file failed on KVM
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.4
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-09 04:18 EDT by xingzhao
Modified: 2009-12-14 16:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-10 03:30:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xingzhao 2009-07-09 04:18:24 EDT
Description of problem:
Attach device from xml file failed on  KVM

Version-Release number of selected component (if applicable):
libvirt-0.6.3-14.el5
kvm-83-84.el5
rhel5.4: 2.6.18-155.el5xen

How reproducible:
100%

Steps to Reproduce:
Add this 2 steps
1. # virsh define rhel5u4.xml
2. # virsh start rhel5u4
3. # virsh attach-device test disk1.xml
disk1.xml info:
  <disk type='file' device='disk'>
     <source file='/var/lib/libvirt/images/RHEL-Server-5.4-64-2.qcow2'/>
     <target dev='hdb' />
   </disk> 

Actual results:
error:Failed to attach device from disk1.xml
error:this function is not supported by the hypervisor:disk bus 'ide'
cannot be hotplgged.

Expected results:
Device attached successfully
Comment 1 xingzhao 2009-07-09 04:29:05 EDT
Steps to Reproduce:
1. # virsh define rhel5u4.xml
2. # virsh start rhel5u4
3. # virsh attach-device rhel5u4 interface.xml
interface.xml info:
<interface type='network'>
 <mac address='54:52:00:2b:d2:64'/>
 <source network='default'/>
</interface> 

Actual results:
error:Failed to attach device from interface.xml
error:this function is not supported by the hypervisor:device type 'interface' cannot be attached.

Expected results:
Device attached successfully
Comment 2 Chris Lalancette 2009-07-09 04:52:03 EDT
Wait, which is it?  In the first comment, you mention this XML:

  <disk type='file' device='disk'>
     <source file='/var/lib/libvirt/images/RHEL-Server-5.4-64-2.qcow2'/>
     <target dev='hdb' />
   </disk> 

Which, indeed, cannot be hotplugged, so there is no bug there.  But then in comment #1, you talk about network attaching.  Which is it?  The first case is not a bug, and I'm not sure about the second case, but they need to be separated since they are two different things.

Chris Lalancette
Comment 3 Daniel Berrange 2009-07-09 05:54:26 EDT
Neither IDE disks, nor network interfaces can be hotplugged.  Only virtio or scsi disks. That said I have a strong feeling virtio / scsi hotplug will be broken anyway:


http://www.redhat.com/archives/libvir-list/2009-July/msg00115.html
Comment 4 xingzhao 2009-07-09 21:54:48 EDT
The following lines is the disk1.xml which I edited.
   <disk type='file' device='disk'>
      <source file='/var/lib/libvirt/images/RHEL-Server-5.4-64-2.qcow2'/>
      <target dev='hdb' />
    </disk>
Comment 5 Chris Lalancette 2009-07-10 03:30:41 EDT
OK.  As both Dan and I point out, that can't work, so this is NOTABUG.  If there is another bug you run across (like the mailing list pointer above), please open that as a separate bug.  And one issue per bug, please.

Chris Lalancette

Note You need to log in before you can comment on or make changes to this bug.