Bug 510523 - anaconda adds "rhgb quiet" despite kickstart config
anaconda adds "rhgb quiet" despite kickstart config
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.4
All Linux
low Severity low
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: Reopened
Depends On:
Blocks: 726828
  Show dependency treegraph
 
Reported: 2009-07-09 12:04 EDT by Aron Griffis
Modified: 2017-05-23 12:14 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-16 10:22:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aron Griffis 2009-07-09 12:04:39 EDT
Description of problem:
My kickstart config says:
bootloader --location=mbr --driveorder=vda,vdb --append="console=ttyS0,115200"

I explicitly removed the "rhgb quiet" part from the anaconda-generated kickstart file.  However when I install with this configuration, the final grub.conf still shows:
kernel /boot/vmlinuz-2.6.18-156.el5 ro root=LABEL=/ console=ttyS0,115200 rhgb quiet

Version-Release number of selected component (if applicable):
5.4 snapshot 1

Additional info:
I observed this installing a virtual machine with 
virt-install ... -x "console=ttyS0,115200 ks=http://foo/ks.cfg"
Comment 1 Aron Griffis 2009-07-09 12:13:42 EDT
simple workaround I'm using in ks.cfg:

%post
sed -i 's/rhgb quiet//' /etc/grub.conf
Comment 2 Chris Lumens 2009-07-28 17:11:48 EDT
--append simply adds the given arguments to the bootloader configs, just like you would expect.  Is having these arguments present causing problems when booting?
Comment 3 Aron Griffis 2009-07-28 17:46:54 EDT
Hi Chris, anaconda puts "rhgb quiet" in the generated ks.cfg, as in: --append="console=ttyS0,115200 rhgb quiet".  That would seem to imply that removing those args would have an effect on the installed host.  I filed this report because I was surprised to see that anaconda will add them regardless.

It's not really a problem for me, just something I didn't expect.  Removing the args in the %post script is sufficient.  I never want them on server installs or test installs; both cases where I want to see the full boot text.

If anaconda is always going to add those arguments, it would perhaps be appropriate to remove them from the generated --append line, where they serve no purpose except to confuse.  However it doesn't bother me if you'd rather punt and concentrate on real bugs. :-)
Comment 4 Chris Lumens 2009-08-25 16:26:23 EDT
This issue should be fixed in the next major release of RHEL, and in Fedora rawhide in the meantime.  Thanks for the idea - it's definitely the kind of little polishing issue we need to spend more time on.  It sounds like you've got a decent workaround for now, but if you do require it in an update release of RHEL5, please raise it through the regular support channels so we can schedule the time for backporting the fix.  Thanks.
Comment 7 Chris Heerschap 2011-08-24 09:06:28 EDT
This bug is still present in RHEL 6u1.  I'd love to see the default for rhgb quiet go away.  Thanks to Aron for the workaround, though.
Comment 8 Saj Goonatilleke 2012-02-21 03:46:29 EST
(In reply to comment #1)
> %post
> sed -i 's/rhgb quiet//' /etc/grub.conf

For anyone still stumbling upon this workaround, note that the quoted 
text will replace the symlink at /etc/grub.conf with a regular file copy 
of /boot/grub/grub.conf.  Over time, the two copies will diverge, 
and -- in the worst case -- you will eventually end up with an 
unbootable system.

If you must, run sed over the symlink's target instead:

    sed -i 's/rhgb quiet//' /boot/grub/grub.conf
Comment 9 Bill Peck 2017-05-23 07:57:50 EDT
(In reply to Saj Goonatilleke from comment #8)
> (In reply to comment #1)
> > %post
> > sed -i 's/rhgb quiet//' /etc/grub.conf
> 
> For anyone still stumbling upon this workaround, note that the quoted 
> text will replace the symlink at /etc/grub.conf with a regular file copy 
> of /boot/grub/grub.conf.  Over time, the two copies will diverge, 
> and -- in the worst case -- you will eventually end up with an 
> unbootable system.
> 
> If you must, run sed over the symlink's target instead:
> 
>     sed -i 's/rhgb quiet//' /boot/grub/grub.conf


And on an atomic system this is a symlink as well!  So you should really add --follow-symlinks to the command.
Comment 10 Dusty Mabe 2017-05-23 12:14:04 EDT
upstream request to have this configurable: https://github.com/rhinstaller/anaconda/issues/1079

Note You need to log in before you can comment on or make changes to this bug.