Bug 51056 - rpm-perl missing necessary .pm files
Summary: rpm-perl missing necessary .pm files
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: roswell
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-06 22:24 UTC by edwinh
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 22:24:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description edwinh 2001-08-06 22:24:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2+) Gecko/20010709

Description of problem:
rpm-perl is missing a few files, isn't it?

These:

/usr/lib/perl5/site_perl/5.6.0/i386-linux/RPM.pm
/usr/lib/perl5/site_perl/5.6.0/i386-linux/RPM/Constants.pm
/usr/lib/perl5/site_perl/5.6.0/i386-linux/RPM/Database.pm
/usr/lib/perl5/site_perl/5.6.0/i386-linux/RPM/Error.pm
/usr/lib/perl5/site_perl/5.6.0/i386-linux/RPM/Header.pm

perl-Perl-RPM used to contain these files and it looks like for Roswell
this was folded in to the main rpm .src.rpm?  But the .pm
files are not in the package only the RPM.so and manpages.


How reproducible:
Always

Steps to Reproduce:
1. any perl script that tries to use the rpm interface; ex. one 
  that has
   
   use RPM::Database;

    ... stuff...

will fail.


	

Actual Results:  "Can't locate RPM/Database.pm" in ....


Expected Results:  .pm files should be there...

Additional info:

Comment 1 Jeff Johnson 2001-08-06 22:35:33 UTC
Fixed in rpm-perl-4.0.3-0.84 IIRC. There's some missing
dependencies, fixed in -0.87. Ther latest build is rpm-4.0.3-0.88.


Note You need to log in before you can comment on or make changes to this bug.