Bug 510568 - shortly after startup thunderbird crashes
shortly after startup thunderbird crashes
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-09 15:43 EDT by Dennis Gilmore
Modified: 2009-09-30 13:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-30 13:51:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2009-07-09 15:43:39 EDT
Description of problem:
shortly after starting thunderbird on rawhide I get the following 

thunderbird

(thunderbird-bin:3861): GLib-GObject-WARNING **: IA__g_object_weak_unref: couldn't find weak ref 0x380ba6b1c0(0x7f57483581e0)
Assertion 'out->clean_up' failed at pulse.c:593, function stream_drain_cb(). Aborting.
/usr/lib64/thunderbird-3.0b3pre/run-mozilla.sh: line 131:  3861 Aborted                 "$prog" ${1+"$@"}


Version-Release number of selected component (if applicable):

thunderbird-3.0-2.4.b3pre.hg.6a6386c16e98.fc11.x86_64

How reproducible:

always

Steps to Reproduce:
1.start thunderbird
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matěj Cepl 2009-07-13 19:39:05 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, could we get output of the command

	rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

Please also install firefox-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install firefox

Then run firefox with a parameter -g. That will start firefox running inside of gdb debugger. Then use command run and do whatever you did to make firefox crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Martin Stransky 2009-09-30 13:22:06 EDT
But looks like pulse audio issue....
Comment 3 Dennis Gilmore 2009-09-30 13:51:10 EDT
its working fine now. the bug was in thunderbird not firefox. so i ignored your request as it was irrelevant.

Note You need to log in before you can comment on or make changes to this bug.