Bug 51060 - fam doesn't update local files modified over nfs.
fam doesn't update local files modified over nfs.
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: fam (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-06 18:38 EDT by Ed McKenzie
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-02 16:04:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed McKenzie 2001-08-06 18:38:15 EDT
If I export a filesystem via nfs and change its contents from a remote
machine, nautilus on the local machine doesn't update to reflect these
changes.  This seems odd, since the files _are_ local...
Comment 1 Alexander Larsson 2001-08-06 19:47:48 EDT
Are you running knfsd?

If so, i think i know what is happening. The write patch of knfsd doesn't
trigger the a dnotify event.
Comment 2 Alexander Larsson 2001-08-06 19:48:19 EDT
Erm. I meant write path.
Comment 3 Ed McKenzie 2001-08-06 19:50:54 EDT
I am running knfsd.
Comment 4 Alexander Larsson 2001-08-08 12:08:16 EDT
Hm. I actually tested this, and it works for me (tm).

I wonder why it doesn't work for you...
Comment 5 Ed McKenzie 2001-08-08 12:28:38 EDT
Actually, it seems there are a few other files it doesn't work for.  Saved 
documents in emacs or AbiWord occasionally show up with zero size until 
I refresh the window ... very strange.

I'll let you know if I figure out what the pattern is.
Comment 6 Owen Taylor 2001-08-10 10:53:21 EDT
If someone wanted to look at the emacs problem, one would first
read the emacs doc's on how it does backup files; it has a number
of modes, not all obvious in operation.
Comment 7 Alexander Larsson 2001-09-28 15:39:21 EDT
I can't reproduce this.
Comment 8 Ed McKenzie 2001-09-28 16:36:04 EDT
This seems to be a more general problem than just nfs.  Sometimes, files saved
from Abiword, Gnumeric, or Staroffice lose their size info (they show up on the
desktop sized 0 or 4k.)  I also sometimes see directory item counts remain
unchanged after creating files there from the shell.

Rawhide/RHN hasn't had updated packages for some time, so maybe I'm just running
outdated/broken packages.  fam is 2.6.4-11, xinetd is 2.3.3-1, nautilus is
1.0.4-40, kernels are 2.4.9-0.5 and -ac16.
Comment 9 Ed McKenzie 2001-10-02 01:08:58 EDT
Ok, this is odd.  It seems even files copied from within Nautilus can show up
with zero sizes.

Any other info I can provide?  I haven't seen anything like this reported
elsewhere, and Nautilus seems to be behaving pretty badly in general, so I might
just have a foobar'd configuration.
Comment 10 Alexander Larsson 2001-10-02 10:48:54 EDT
The nonchanging directory counts is "correct". Nautilus does not watch all
subdirs of the current dir. That would be a tad to expensive.
Comment 11 Alexander Larsson 2001-10-02 11:16:43 EDT
Ok. I see this now.
I think it is a race between AbiWord, fam and Nautilus.
Nautilus gets the first notification of change, when the file is truncated, but
then for some reason does not get, or ignores the rest of the changes.
Comment 12 Alexander Larsson 2001-10-02 16:04:32 EDT
This is a race in fam.
If you get more than one change of a file in the same second fam cannot detect
that, since the resolution of ctime is only one second.
This will be sort of hard to fix. I think it involves holding back the change
events for one second.
Comment 13 Alexander Larsson 2001-10-26 11:24:03 EDT
This is fixed in 2.6.4-13

Note You need to log in before you can comment on or make changes to this bug.