Bug 510600 - snd_hda_intel + pulseaudio = sound gets muted for unknown reason upon startup
snd_hda_intel + pulseaudio = sound gets muted for unknown reason upon startup
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
19
All Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-09 16:45 EDT by Tomasz Chrzczonowicz
Modified: 2013-09-19 04:17 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 04:17:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info (20.88 KB, text/plain)
2009-07-09 16:50 EDT, Tomasz Chrzczonowicz
no flags Details

  None (edit)
Description Tomasz Chrzczonowicz 2009-07-09 16:45:24 EDT
Description of problem:

The sound gets muted each time and I boot into Fedora and has to turned up manually both in the general mixer and in the first application that I use.

Version-Release number of selected component (if applicable):

alsa-plugins-pulseaudio.i586        1.0.18-3.fc11             installed         
pulseaudio.i586                     0.9.15-14.fc11            installed         
pulseaudio-debuginfo.i586           0.9.15-14.fc11            @updates-debuginfo
pulseaudio-esound-compat.i586       0.9.15-14.fc11            installed         
pulseaudio-libs.i586                0.9.15-14.fc11            installed         
pulseaudio-libs-glib2.i586          0.9.15-14.fc11            installed         
pulseaudio-libs-zeroconf.i586       0.9.15-14.fc11            @updates          
pulseaudio-module-bluetooth.i586    0.9.15-14.fc11            installed         
pulseaudio-module-gconf.i586        0.9.15-14.fc11            installed         
pulseaudio-module-jack.i586         0.9.15-14.fc11            @updates          
pulseaudio-module-x11.i586          0.9.15-14.fc11            installed         
pulseaudio-utils.i586               0.9.15-14.fc11            installed         

alsa-lib.i586                              1.0.20-1.fc11               installed
alsa-plugins-pulseaudio.i586               1.0.18-3.fc11               installed
alsa-utils.i586                            1.0.20-3.fc11               installed
bluez-alsa.i586                            4.37-2.fc11                 installed

Additional info:

My smolt profile: http://www.smolts.org/show?uuid=pub_6566df0c-e8ae-41c6-ac3b-de190be345c7
Comment 1 Tomasz Chrzczonowicz 2009-07-09 16:50:57 EDT
Created attachment 351168 [details]
alsa-info
Comment 2 Adam Williamson 2009-07-15 17:05:14 EDT
This is not an AlsaVolume bug. Please read the information on that bug before marking bugs as blocking it.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Lennart Poettering 2009-07-23 08:50:52 EDT
Hmm, which mixer are you using for this? gnome-volume-control?
Comment 4 Tomasz Chrzczonowicz 2009-07-23 10:57:56 EDT
Mostly gnome-volume-control and gnome-volume-control-applet
Comment 5 Lennart Poettering 2009-07-24 21:00:12 EDT
Fixed in PA git. Will soon land in rawhide.
Comment 6 Tomasz Chrzczonowicz 2009-08-25 17:20:59 EDT
It's still not fixed in Fedora 12 Alpha.I think it should block Fedora 12.
Comment 7 Lennart Poettering 2009-08-25 21:28:16 EDT
pa in the alpha is quite out of date. please use latest pa version from rawhide.
Comment 8 Jaroslav Škarvada 2013-02-13 05:27:50 EST
Reopenning, I am hitting the same problem since F15 (may be longer), reproducer:

# pkill pulseaudio

Audio is muted (hda-intel master gets muted), can be unmuted by e.g.:
# alsaunmute
Comment 9 Fedora End Of Life 2013-07-04 02:50:04 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 10 Fedora End Of Life 2013-08-01 14:28:39 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 11 Jaroslav Škarvada 2013-08-02 10:15:31 EDT
Same problem on F19. Any hint how to prevent pulseaudio from doing this?
Comment 12 Raymond 2013-08-03 07:50:50 EDT
alc660 did not has any hardware volume control and PCM playback is a softvol 

Simple mixer control 'Master',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Headphone',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [on]
  Front Right: Playback [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 170 [67%] [-17.00dB]
  Front Right: Playback 170 [67%] [-17.00dB]
Simple mixer control 'Front',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [on]
  Front Right: Playback [on]


you have to provide pulseaudio log and examine how pulseaudio implement software volume control when there is no hardware volume.e
Comment 13 Jaroslav Škarvada 2013-08-14 09:03:05 EDT
(In reply to Raymond from comment #12)
> you have to provide pulseaudio log and examine how pulseaudio implement
> software volume control when there is no hardware volume.e
>
Well, this is something I was afraid of, that I will have to fix it myself :)

IIRC it worked OK in F14 and bellow (maybe earlier, I cannot remember), but was broken by update to F15 and is broken today.
Comment 14 Raymond 2013-08-14 10:08:42 EDT
http://lists.freedesktop.org/mailman/listinfo/pulseaudio-discuss

you have to ask in pulseaudio mailing list

pulseaudio log when you change the volume 

pulseaudio -vvvv

pactl list

http://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/PulseAudioStoleMyVolumes/

When PulsaAudio is asked to set a specific volume x in dB, it will go from the outermost to the innermost mixer element and apply the volume there: on consumer cards, the "Master" element is usually the outermost. Hence first it is asked to apply the volume x there. Of course, the hardware usually allows only a number of discrete volume steps, hence what can be applied is only a volume x' with x' near (and usually lower than) x. As next step we then subtract the volume adjustment done in 'Master' from the volume we want to set y = x - x'. (Remember that dB is logarithmic, so we actually divide the linear factors here). Then we apply y on the next element in the pipeline, in this case "PCM". Again, the hardware only knows a discrete step y', that is near to the requested y. Then again we subtract what we set from what we wanted: z = y - y'. Since this is the last element in our pipeline we apply that volume z in software. This example pipeline is very short. Depending on the sound card used the pipeline might get much longer.
Comment 15 Jaroslav Škarvada 2013-08-14 10:12:49 EDT
(In reply to Raymond from comment #14)
Thanks for info, I will look on it.
Comment 16 Raymond 2013-08-14 11:40:41 EDT
http://cgit.freedesktop.org/pulseaudio/pulseaudio/tree/src/modules/alsa/mixer/paths

pcm volume seem defined in analog-output.conf.common

but your alc660 did not has headphone playback volume nor front playback volume which are defined in analog-output-headphone.conf and analog-output-lineout.conf
Comment 17 Raymond 2013-09-03 11:19:19 EDT


http://fedoraproject.org/wiki/How_to_debug_PulseAudio_problems

post the pulseaudio verbose log

please note that alc660 does not support 44100Hz

Codec: Realtek ALC660
Address: 0
Vendor Id: 0x10ec0861
Subsystem Id: 0x10430505
Revision Id: 0x100340
No Modem Function Group found
Default PCM:
    rates [0x140]: 48000 96000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
Comment 18 Jaroslav Škarvada 2013-09-03 12:01:38 EDT
Thanks for your response. After some recent software update it seems it started automagically work (f19) :).  Let me check it across several restarts.
Comment 19 Jaroslav Škarvada 2013-09-19 04:17:52 EDT
I can confirm it works correctly now (at least with my HW), thus closing.

Note You need to log in before you can comment on or make changes to this bug.