Bug 510606 - Ensure KVM Guest management actions work as expected on clients
Ensure KVM Guest management actions work as expected on clients
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Virtualization (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Milan Zázrivec
Petr Sklenar
:
: 529695 (view as bug list)
Depends On:
Blocks: sat531-kvm
  Show dependency treegraph
 
Reported: 2009-07-09 17:00 EDT by Pradeep Kilambi
Modified: 2010-02-23 07:25 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-04 05:48:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2009-07-09 17:00:09 EDT
Description of problem:

A user with a kvm host registered to satellite with virt entitlement should be able to manage its guests. The manages actions currently supported for Xen are 'Start', 'ShutDown', 'Restart', 'Suspend', 'Resume'.

Also we should be able to change the vcpus and memory. Note the this might need a guest reboot to reflect the change.

There are currently few issues with kvm guest handling in libvirt for RHEL-5.4~
- reboot is not implemented due to bug#496537
- Start fails in selinux enforcing mode  bug#510525

So these two are expected until those bugs are addressed in RHEL.
Comment 5 wes hayutin 2009-10-07 22:22:30 EDT
some output from trying on a sat530 w/ libvirt

\n<params>\n<param>\n<value><string>0be8b901a6334988b57223ec656734fe</string></value>\n</param>\n</params>\n</methodCall>\n", 'version': 2, 'id': 1121}
D: handle_action actionid = 1121, version = 2
D: do_call virt.shutdown ('0be8b901a6334988b57223ec656734fe',)
libvir: QEMU error : operation failed: shutdown operation failed
D: Sending back response ((6,), 'Fatal error in Python code occured', {})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
Loaded plugins: rhnplugin
D: opening  db environment /var/lib/rpm/Packages joinenv
Comment 6 Milan Zázrivec 2009-10-23 08:32:12 EDT
Some code parts used by rhn-kickstart package removed with commit
309403ad69b27b46c8419d221811219606dc99a6 (spacewalk.git master) were
returned back by commit 987e596c172fd24d8535d3d4919f40b485ba6484
(spacewalk.git master)
Comment 7 Milan Zázrivec 2009-10-23 08:33:15 EDT
*** Bug 529695 has been marked as a duplicate of this bug. ***
Comment 8 Milan Zázrivec 2009-11-02 12:45:30 EST
satellite.git SATELLITE-5.3:

a70e08610d0ee46b546b60271e07c4dc688238dc
291998ba68aa396061c10ec4a823fbb3775f941b
Comment 9 Milan Zázrivec 2009-11-03 05:02:55 EST
Tagged & built: spacewalk-koan-0.1.11-13 rhn-virtualization-5.3.0-13
Comment 10 Milan Zázrivec 2009-11-11 10:06:41 EST
New spacewalk-koan & rhn-virtualization have been pushed into webqa.
Comment 13 errata-xmlrpc 2009-12-04 05:48:17 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1639.html

Note You need to log in before you can comment on or make changes to this bug.