Bug 510608 - libogg/libvorbis -devel-docs packages broken
libogg/libvorbis -devel-docs packages broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libogg (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Rakesh Pandit
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-09 17:05 EDT by Edward Sheldrake
Modified: 2010-02-24 22:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 03:52:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.spec changes to fix devel docs (579 bytes, patch)
2009-07-18 14:22 EDT, Edward Sheldrake
no flags Details | Diff

  None (edit)
Description Edward Sheldrake 2009-07-09 17:05:36 EDT
Description of problem:
The libogg-devel-docs and libvorbis-devel-docs packages don't contain any developer docs, just copies of README AUTHORS COPYING again.

Version-Release number of selected component (if applicable):
libogg-devel-docs-1.1.4-1.fc12.noarch.rpm
libvorbis-devel-docs-1.2.2-2.fc12.noarch.rpm

How reproducible:
Always.

Steps to Reproduce:
1. Install libogg-devel-docs and libvorbis-devel-docs
2.
3.
  
Actual results:
No developer docs are installed. Actually nothing gets installed, the same files are already in the main libogg/libvorbis packages.

Expected results:
The devel docs get installed.

Additional info:
It's since the rc1 got removed, the developer docs directory is now the same as where the main package %doc line puts its files, and %doc removes the directory first.
Comment 1 Edward Sheldrake 2009-07-18 14:22:09 EDT
Created attachment 354259 [details]
.spec changes to fix devel docs

If libogg-devel-docs contained some docs, someone might also notice the broken link in index.html to libogg/index.html, the Makefile installs the api docs into an "ogg" subdirectory.
Comment 2 Rakesh Pandit 2009-11-10 03:52:59 EST
Thanks for patch .. and sorry for being NON responsive for this late.

Pushed .. and will be in tomorrow's rawhide.
Comment 3 Robert Ransom 2010-02-24 22:24:15 EST
(In reply to comment #2)
> Thanks for patch .. and sorry for being NON responsive for this late.
> 
> Pushed .. and will be in tomorrow's rawhide.    

This needs to be fixed in the Fedora 11 and 12 repositories.

Note You need to log in before you can comment on or make changes to this bug.