Bug 510627 - crash during run /dev/md0 RAID 1
crash during run /dev/md0 RAID 1
Status: CLOSED DUPLICATE of bug 504826
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-09 17:47 EDT by Ray Todd Stevens
Modified: 2014-01-21 18:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-10 12:12:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Todd Stevens 2009-07-09 17:47:16 EDT
When I try and run preupgrade to upgrade one of our servers it stops in loading stage 2 and i get the following error message

/usr/lib/python2.5/site-packages/yum/__init__.py:181: UserWarning: Use .preconf instead of passing args to _getConfig
  warnings.warn('Use .preconf instead of passing args to _getConfig')
Loaded plugins: blacklist, refresh-packagekit, whiteout
preupgrade-main (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-11&arch=$basearch
  now: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-11&arch=i386
preupgrade (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/11/Fedora/$basearch/os
  now: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/11/Fedora/i386/os
preupgrade-fedora (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-11&arch=i386
  now: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-11&arch=i386
preupgrade-updates (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f11&arch=i386
  now: http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f11&arch=i386
Fetched treeinfo from http://fedora.secsup.org/linux/releases/11/Fedora/i386/os//.treeinfo
treeinfo timestamp: Tue Jun  2 18:01:41 2009
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 238, in on_assistant_apply
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 257, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 473, in main_preupgrade
    bootdevpath = bootpath_to_anacondapath(stage2_abs,UUID=True)
  File "/usr/lib/python2.5/site-packages/preupgrade/dev.py", line 86, in bootpath_to_anacondapath
    raise PUError, "/boot is on RAID device %s" % bootdev
NameError: global name 'PUError' is not defined
Comment 1 Will Woods 2009-07-10 12:12:20 EDT

*** This bug has been marked as a duplicate of bug 504826 ***

Note You need to log in before you can comment on or make changes to this bug.