Bug 51063 - USB hangs on boot in UP mode
USB hangs on boot in UP mode
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
roswell
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-06 19:40 EDT by James Cook
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-07 18:12:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
VA patch (for 2.2 kernel!) (32.84 KB, patch)
2001-08-31 01:04 EDT, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description James Cook 2001-08-06 19:40:01 EDT
Description of problem:
I pop the first CD into the drive and boot the machine.  It hits the
ldlinux screen and I whack the enter key to start the installer.  Standard
messages scroll by until I get to the following lines:

running install...
running /sbin/loader

and then the system locks up tight.  I've tried various combinations of
no-probing, expert and text-only options.  The disk works fine in both of
my Athlon systems and on a Dell machine at work.  The system that I'm
having trouble with is a VALinux 1000 machine (quite similar to the IBM
Netfinity 4000r) - dual processor P3 with the Symbios Logic SCSI controller.

How reproducible:
Always

Steps to Reproduce:
1. Insert CD into the drive and turn the power on
2. Hit enter at the LDLinux screen
3. Wait for the lockup ;)
Comment 1 Michael Fulbright 2001-08-07 09:52:41 EDT
Please look at VC3 (switch over as soon as you can) and let us know the last few
lines that get printed out.   Also VC4 is helpful.
Comment 2 Glen Foster 2001-08-07 16:08:51 EDT
We (Red Hat) should really try to fix this before next release.
Comment 3 James Cook 2001-08-07 20:04:00 EDT
It appears to have something to do with USB.  What shows up on VC4 prior to the
hang is:

<6>usb.c: registered new driver usbdevfs
<6>usb.c: registered new driver hub
<6>usb-uhci.c: $Revision: 1.259 $ time 15:38:25 Jul 24 2001
<6>usb-uhci.c: High bandwidth mode enabled
<6>usb-uhci.c: USB UHCI at I/O 0xef80, IRQ 9
<4>usb-uhci.c: Detected 2 ports

On VC3 it says:

* looking for usb controllers
* found USB controller usb-uhci
* going to insmod usbcore.o (path is NULL)
* going to insmod usb-uhci.o (path is NULL)

On the theory that USB was causing the installer to hang, I went into the BIOS
and disabled USB.  The installer came up just fine at that point.  That's all
well and good, but I'm using a USB keyboard and mouse on it ... ;)  So, another
reboot to re-enable the USB and to try fiddling with some of the USB settings in
the BIOS.  Enabling or disabling "Port 64/60 Emulation" didn't do anything for
me, nor did enabling or disabling "USB KB/Mouse Legacy Support".  So, to make
the installer happy, I scrounged up an old PS/2 keyboard and mouse and used that
instead.

Once installed, USB functions just fine, it's just the installer that has heartburn.
Comment 4 Michael Fulbright 2001-08-08 21:58:50 EDT
If you have usb enabled in the bios, and boot with 'nousb' on the command line
when booting the installer, does it not hang? I know this will not let you use
the keyboard and mouse, just want to check this helps with the hanging.
Comment 5 James Cook 2001-08-08 22:12:53 EDT
Doing a "linux nousb" at the ldlinux prompt made the load up just fine.
Comment 6 James Cook 2001-08-08 22:13:46 EDT
Ugh, that english doesn't parse very well.  s/made the load up/made the
installer load up/  (duh)
Comment 7 James Cook 2001-08-12 13:05:05 EDT
It occurs to me that if it'd be helpful to see the machine, I live in Durham and
it wouldn't be a problem for me to bring the machine by some time.  Besides,
it'd be fun to get the nickel tour.  :)
Comment 8 Michael Fulbright 2001-08-13 11:27:21 EDT
There are known problems with some machines and USB in the kernel, which is why
we have the 'nousb' option.

Passing to the kernel team, this appears to be related to drivers and hardware.
Comment 9 Pete Zaitcev 2001-08-13 12:57:54 EDT
I have two questions for the requestor.

1. It was indicated that switching VTs worked.
When switching to tty2, did the bash prompt respond to <Enter>?

2. Did hitting <alt>-<sysrq>-P produce anything?
It may be disabled sometimes.

I assume you may test this without destroying the current
installation because the hang happens very early.
Comment 10 James Cook 2001-08-19 14:00:18 EDT
Sorry it took me so long to check this ...

In regards to the first question, the shell is never launched because the hang
occurs during the rinning of /sbin/loader.  Once the system hangs, hitting
alt-sysrq-p has no effect.
Comment 11 James Cook 2001-08-19 14:01:06 EDT
Gah, I can spell, really I can.  s/rinning/running/
Comment 12 Pete Zaitcev 2001-08-19 15:08:06 EDT
The note of 08/07 says "once [OS] is installed, USB works fine".
That means the difference between i386-BOOT and i686smp kernels
is significant.

Can you try "nousb" with regular reboot and see if the thing hangs
(or better yet, use i686 kernel that is installed by default
even on SMP machines)?

BTW, Never enable "Port 60/64 Emulation" - I do not guarantee
that psaux driver is compatible with all [broken] SMM emulators
that BIOS vendors ship.

Comment 13 Pete Zaitcev 2001-08-19 15:29:26 EDT
Oops, I am sorry - I meant "nosmp", not "nousb".
See if it locks in UP mode.
Comment 14 James Cook 2001-08-19 18:57:17 EDT
Aha!  That's what that port 64/60 jazz is all about!  :)  Thanks for that tidbit.  

Booted the system up off the harddrive and told Grub to load the
single-processor kernel.  System hung when it went to initialize the USB
controller.  Intriguing!
Comment 15 James Cook 2001-08-27 16:51:44 EDT
Just tried the Rowswell 2 release, same issue when using the uni-processor
kernel.  Installer also still hangs when not specifying the nousb parameter.
Comment 16 Pete Zaitcev 2001-08-27 18:36:31 EDT
Since you have the hardware, we have to debug on your
box, if you are interested in pursuing it.

Can you compile kernels, or do you need RPMs from me?

Also, please verify for me that you box is not based
on 440GX chipset.
Comment 17 James Cook 2001-08-28 16:31:05 EDT
I'd be happy to help debug.  It's not a problem to compile kernels either.  :)

The board is based on the 440GX chipset for what it's worth.
Comment 18 Pete Zaitcev 2001-08-31 01:04:09 EDT
Created attachment 30254 [details]
VA patch (for 2.2 kernel!)
Comment 19 Arjan van de Ven 2001-09-07 15:41:36 EDT
Could you try adding "apic" to the syslinux prompt ?
eg type "linux apic" on the very very first screen ?
Comment 20 James Cook 2001-09-07 18:12:52 EDT
The apic option works great!  The installer booted right up and detected my USB
stuff.
Comment 21 Pete Zaitcev 2001-09-20 14:27:47 EDT
I discussed it with the team and we decided not to try
to pull VA fix. It is a vendor specific workaround for
a broken hardware. Also, "apic" works.

Note You need to log in before you can comment on or make changes to this bug.