Bug 510632 - [Stratus 5.5 bug] user action required to load cdrom:ks.cfg when booted from a USB dvd drive.
[Stratus 5.5 bug] user action required to load cdrom:ks.cfg when booted from ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
All Linux
high Severity high
: rc
: 5.5
Assigned To: Jim Paradis
Red Hat Kernel QE team
: OtherQA, Regression
Depends On:
Blocks: 533192 533941 5.4/TechnicalNotes 525215
  Show dependency treegraph
 
Reported: 2009-07-09 18:36 EDT by Rich Johnson
Modified: 2010-01-11 18:18 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The kernel is unable to properly detect whether there is media present in a CD-ROM drive during kickstart installs. The function to check the presence of media incorrectly interprets the "logical unit is becoming ready" sense, returning that the drive is ready when it is not. To work around this issue, wait several seconds between inserting a CD and asking the installer (anaconda) to refresh the CD.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-01 16:01:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rich Johnson 2009-07-09 18:36:38 EDT
Description of problem:
User cannot avoid the dialog to specify the kickstart When booting from a USB dvd and specifying "ks=cdrom.ks.cfg" 

- default boot clause contains:
  kernel vmlinuz
  append initrd=initrd.img ks=cdrom:ks.cfg
- kickstart file "ks.cfg" is present in the top level directory of the CD.

Version-Release number of selected component (if applicable):
5.4-Beta.

Actual Results:
- User is presented with a prefilled dialog listing "CDROM:ks.cfg" as the kickstart.

- User must select "OK" to proceed.

Expected results:
- kickstart specified on the boot clause should load without requiring user interaction.

Additional info:  
 - possibly related to 495439

Suspect a problem sensing the presence of CDROM media in a timely manner.
If the CDROM method is selected and the CD is replaced and "OK" is selected right away the CDROM is ejected by anaconda.  If the user waits about 15-20 seconds after replacing the CD before selecting "OK" the media is accepted and installation begins.   The drive light blinks about every second for about 20 seconds after loading.
Comment 1 Andrius Benokraitis 2009-07-13 23:41:31 EDT
Stratus - did this work properly in RHEL 5.3 before?
Comment 2 Chris Lumens 2009-07-14 11:31:39 EDT
This appears to be due to a kernel bug when detecting the media.  This was fixed in the kernel for F11.  If you could test that, it'd be helpful in deciding what to do with this bug for a RHEL5 update.  The patch in question is here:

http://kerneltrap.org/mailarchive/git-commits-head/2009/5/3/5621824/thread#mid-5621824
Comment 3 Chris Lumens 2009-07-14 11:31:39 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
The kernel is unable to properly detect whether there is media present in a CD-ROM drive on kickstart installs.  This is because the function to check the presence of media misinterprets the "logical unit is becoming ready" sense, returning that the drive is ready rather than it it not yet.  A potential workaround is to wait for several seconds between inserting a CD and telling anaconda to try again.
Comment 4 Rich Johnson 2009-07-14 16:24:51 EDT
(In reply to comment #1)
> Stratus - did this work properly in RHEL 5.3 before?  

No it did not.  The symptom is also present with RHEL5.3 GA.
Comment 5 Rich Johnson 2009-07-14 17:04:12 EDT
(In reply to comment #2)
> This appears to be due to a kernel bug when detecting the media.  This was
> fixed in the kernel for F11.  If you could test that, it'd be helpful in
> deciding what to do with this bug for a RHEL5 update.  The patch in question is
> here:
> 
> http://kerneltrap.org/mailarchive/git-commits-head/2009/5/3/5621824/thread#mid-5621824  

Booting the same H/W from Fedora 11 ISO does not exibit the symptom.  
cdrom:ks.cfg is loaded w/o requiring user interaction.
Comment 6 Andrius Benokraitis 2009-07-14 17:18:55 EDT
Rich - since this problem was also exhibited in RHEL 5.3, it sounds more of a longer-term issue, and at this point in RHEL 5.4 I don't believe this warrants fixing in RHEL 5.4 since there is also an easy workaround in the meantime. A release note is already in the works for RHEL 5.4 GA.

Will this cause substantial heartburn for you all if this doesn't make 5.4?

Also changing this to component: kernel per the proposed patch.

Great find, Chris!
Comment 7 Robert N. Evans 2009-07-15 08:15:58 EDT
If there is a release note for RHEL 5.4 GA concerning this problem, it is sufficient for Stratus customers.
Comment 8 RHEL Product and Program Management 2009-07-22 11:34:05 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 12 Ryan Lerch 2009-08-18 19:20:24 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1,2 @@
-The kernel is unable to properly detect whether there is media present in a CD-ROM drive on kickstart installs.  This is because the function to check the presence of media misinterprets the "logical unit is becoming ready" sense, returning that the drive is ready rather than it it not yet.  A potential workaround is to wait for several seconds between inserting a CD and telling anaconda to try again.+The kernel is unable to properly detect whether there is media present in a CD-ROM drive during kickstart installs. The function to check the
+presence of media incorrectly interprets the "logical unit is becoming ready" sense, returning that the drive is ready when it is not. To work around this issue, wait several seconds between inserting a CD and asking the installer (anaconda) to refresh the CD.
Comment 14 Jim Paradis 2009-10-14 17:15:35 EDT
Stratus approves this release note change.
Comment 15 Chris Ward 2009-10-15 09:15:05 EDT
@Stratus,

We need to confirm that there is commitment to test 
for the resolution of this request during the RHEL 5.5 test
phase, if it is accepted into the release. 

Please post a confirmation before Oct 16th, 2009, 
including the contact information for testing engineers.
Comment 16 Rich Johnson 2009-10-15 11:50:05 EDT
I am signed up to test from the Stratus side.
Comment 17 Andrius Benokraitis 2009-12-01 16:01:15 EST
Looks like the release note has been published, will close this bugzilla now.

Note You need to log in before you can comment on or make changes to this bug.