Bug 510659 - easy_install should be in python-setuptools, not python-setuptools-devel
easy_install should be in python-setuptools, not python-setuptools-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-setuptools (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Toshio Ernie Kuratomi
Fedora Extras Quality Assurance
: Reopened
Depends On: 531901
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-10 01:01 EDT by Andrew McNabb
Modified: 2009-11-03 16:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-03 16:12:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew McNabb 2009-07-10 01:01:32 EDT
The "easy_install" program is intended for end users to install packages.  Since it is not a development tool, I believe it should be in the python-setuptools package rather than the python-setuptools-devel package.
Comment 1 Konstantin Ryabitsev 2009-07-10 09:24:32 EDT
The reason why it's in a separate -devel subpackage is because it requires python-devel. Please see #251645 and #240707 for more info.
Comment 2 Andrew McNabb 2009-10-29 15:25:26 EDT
I've been thinking about this more, and I really think that there are missing dependencies here.  The python-setuptools-devel package has two files:

1) /usr/bin/easy_install: a 9 line script that imports and runs pkg_resources.load_entry_point

2) /usr/lib/python2.6/site-packages/easy_install.py: a 5 line script that loads and runs setuptools.command.easy_install.main

The actual dependency on python-devel happens in the distutils libraries (which is part of the Python package), not in these trivial scripts, so the python-setuptools package should be able to depend on python package instead of python-devel.  It really looks like they did the wrong thing in bug #251645.  This will need to be fixed in the python package before it can be fixed in setuptools, so I've created bug #531901 for python.
Comment 3 Toshio Ernie Kuratomi 2009-10-29 20:25:41 EDT
Sure.  Once bug #531901 is resolved, I'll be happy to change the python-setuptools package.  I think we want to pull everything back into a single package with a Provides: python-setuptools = %{version} Does that sound good to you?
Comment 4 Andrew McNabb 2009-11-03 15:00:12 EST
Now that dmalcolm has fixed bug #531901 in python-2.6.4-2.fc13, it should be possible to combine python-setuptools-devel into python-setuptools (for fc13, anyway).
Comment 5 Toshio Ernie Kuratomi 2009-11-03 16:12:36 EST
Done:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1786594

Note You need to log in before you can comment on or make changes to this bug.