Bug 510666 - gtk2-immodules needs xinput .conf files for immodules
gtk2-immodules needs xinput .conf files for immodules
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-10 02:34 EDT by Jens Petersen
Modified: 2009-09-17 19:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.16.6-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-15 03:45:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-07-10 02:34:42 EDT
Description of problem:
As discussed in bug 505100 im-cedilla.so (and others) are missing
xinput.d conf files so it is hard to enable them from im-chooser

Additional info:
Tagoh-san posted a sample im-cedilla.conf (attachment 351200 [details])
in the above bug.
Comment 1 Jens Petersen 2009-07-10 02:40:28 EDT
Some of original comment by Akira which prompted this bug:

(In reply to comment #25)
> Created an attachment (id=351200) [details]
> im-cedilla.conf
> 
> Just a suggestion if using cedilla immodule in gtk+ is a solution:
> 
> How about put im-cedilla.so to the separate package like gtk-immodules-cedilla
> with the attached imsettings configuration file? [...] although
> you need to choose that with im-chooser manually and need a bit updates on
> imsettings to support immodule only configuration.
:

Anyway leaving this idea with Matthias - I still hope we can fix
Brazilian cedilla issue with suitable xkb kbd layout config.
Comment 2 Matthias Clasen 2009-07-10 09:52:19 EDT
I've put the im-cedilla.conf in gtk2-2.17.3-3.fc12. Let me know if it doesn't work...
Comment 3 Rodrigo Padula de Oliveira 2009-09-02 11:02:11 EDT
I updated my Fedora 11 to the new packages and the cedilla isnt working again
Comment 4 Jens Petersen 2009-09-03 05:36:33 EDT
I haven't been able to get it working either actually
though in any version of fedora but I might well be missing something.

Can you describe exactly how to get it working?
Comment 5 Jens Petersen 2009-09-03 06:19:24 EDT
(In reply to comment #4)

Nevermind I got it working now...

In F12 setting im-cedilla as the immodule in im-chooser
or using GTK_IM_MODULE=cedilla "dead_acute"
(eg using US Latin American layout
the ' deadkey to the right of P) combines with c
to generate ç.

(In reply to comment #3)
> I updated my Fedora 11 to the new packages and the cedilla isnt working again  

Do you install gtk2-immodules?
Comment 6 Jens Petersen 2009-09-03 06:26:52 EDT
Matthias, could we add im-cedilla.conf for F11 too?

Tagoh-san: would that work in F11 imsettings?

If so then let's reopen against F11.
Comment 7 Rodrigo Padula de Oliveira 2009-09-03 10:16:01 EDT
Yes, I have gtk2-immodules installed.

The cedilla isn't working by default in my Fedora 11 in portuguese with keyboard US International.

We need this feature again I dont now why it's not working after the package updates.  You patch was removed ?
Comment 8 Rodrigo Padula de Oliveira 2009-09-03 10:21:57 EDT
We need this package installed by default in Fedora because it is generating a lot of claims in our forum.


It's a big usability problem and it not happens with others OS and Linux Distributions.


In all systems, when we choose Brazilian Portuguese Language + Us International Keyboard when we  press  ' + c we have ç.

Please, we need an update urgently for Fedora 11
Comment 9 Akira TAGOH 2009-09-07 00:13:00 EDT
(In reply to comment #6)
> Matthias, could we add im-cedilla.conf for F11 too?
> 
> Tagoh-san: would that work in F11 imsettings?

Yes, that should works with the latest update of imsettings.
Comment 10 Jens Petersen 2009-09-07 02:18:11 EDT
Ok then Sorry to recycle but reopening for f11.
Comment 11 Rodrigo Padula de Oliveira 2009-09-08 09:04:47 EDT
I set the English International keyboard again using:

[root@shadownman ~]# system-config-keyboard 
Loading /lib/kbd/keymaps/i386/qwerty/us-acentos.map.gz


The ' + c isn't working properly yet.
Comment 12 Jens Petersen 2009-09-08 13:23:04 EDT
Rodrigo: Did you test with gtk2-immodules and GTK_IM_MODULE=cedilla ?
Comment 13 Rodrigo Padula de Oliveira 2009-09-08 16:21:29 EDT
We need to add it by default in Fedora, when the user set language = portuguese and Us International keyboard.

The problem was solved before but comeback in the last Fedora 11 updates.

This is a big usability problem for Brazilians
Comment 14 Rodrigo Padula de Oliveira 2009-09-11 14:43:07 EDT
I tryed to replace ibus by cedilla in the file /etc/alternatives/xinputrc but the problem persist.

GTK_IM_MODULE=cedilla
Comment 15 Fedora Update System 2009-09-15 03:45:14 EDT
gtk2-2.16.6-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Jens Petersen 2009-09-17 02:41:31 EDT
(In reply to comment #14)
> I tryed to replace ibus by cedilla in the file /etc/alternatives/xinputrc but
> the problem persist.

Use im-chooser and select cedilla.
Comment 17 Rodrigo Padula de Oliveira 2009-09-17 10:38:55 EDT
Uou!! Now it's working pretty fine!

How we cant activate it by default when the user set the language Brazilian Portuguese and the keyboard USA International ?
Comment 18 Jens Petersen 2009-09-17 19:44:38 EDT
(In reply to comment #17)
> How we cant activate it by default when the user set the language Brazilian
> Portuguese and the keyboard USA International ?  

That is a pretty specific case so hard to do IMO. :-(

As said before im-cedilla.so is a hack and not the Right Thing
- let's say we have it for "backwards compatibility".
Comment 19 Jens Petersen 2009-09-17 19:48:17 EDT
(Just for the record and reference - these are the steps I used:
1. install gtk2-immodules
2. im-chooser -> select cedilla
3. Restart desktop with "USA (International with dead keys)"
4. ' + c -> ç )

Note You need to log in before you can comment on or make changes to this bug.