Bug 510671 - evolution hangs sporadically
evolution hangs sporadically
Status: CLOSED DUPLICATE of bug 498871
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-10 04:02 EDT by Pontus Enhager
Modified: 2009-07-10 10:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-10 10:05:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (335.17 KB, text/plain)
2009-07-10 09:01 EDT, Pontus Enhager
no flags Details
evolution-data-server bt log (2.30 KB, application/octet-stream)
2009-07-10 09:05 EDT, Pontus Enhager
no flags Details

  None (edit)
Description Pontus Enhager 2009-07-10 04:02:06 EDT
Description of problem:
sometimes evolution hangs, it just stops responding

Version-Release number of selected component (if applicable):
[pontus@selleri ~]$ rpm -qa |grep evolution
evolution-help-2.26.2-1.fc11.noarch
evolution-data-server-doc-2.26.2-1.fc11.noarch
evolution-data-server-devel-2.26.2-1.fc11.x86_64
evolution-2.26.2-1.fc11.x86_64
evolution-perl-2.26.2-1.fc11.x86_64
evolution-debuginfo-2.26.2-1.fc11.x86_64
evolution-data-server-debuginfo-2.26.2-1.fc11.x86_64
evolution-data-server-2.26.2-1.fc11.x86_64


How reproducible:
usually after evolution have been running for quite a while (idling), but not necessarirly very long time 

Steps to Reproduce:
1.wait
2.see
3.
  
Actual results:
hang, no response

Expected results:
interesting emails from friends, some spam, bugmails, even more spam

Additional info:
Comment 1 Milan Crha 2009-07-10 04:36:05 EDT
Thanks for a bug report. Reproducing such bug is usually quite hard. When it hangs for you again, could you attach gdb to the running process and get a backtrace of the actual state? It will get us some overview what it does.

You can do that for example by this:
a) find out evolution's process ID (PID), for example with:
   $ ps -A | grep evolution
b) then run this command:
   $ gdb --batch --ex "t a a bt" -pid=PID &>bt.log
c) attach here the resulting bt.log file

Maybe do the same for evolution-data-server process.
Thanks in advance.
Comment 2 Pontus Enhager 2009-07-10 09:01:18 EDT
Created attachment 351256 [details]
backtrace

i DID attach the backtrace this morning - but apparently it did not stick...

another try
Comment 3 Pontus Enhager 2009-07-10 09:04:40 EDT
here you have also the e-d-s backtrace - i kept the stuck process for now - so i hope it doesn't matter that these backtraces are made at two entirerly different occasions
Comment 4 Pontus Enhager 2009-07-10 09:05:13 EDT
Created attachment 351257 [details]
evolution-data-server bt log
Comment 5 Milan Crha 2009-07-10 10:05:19 EDT
Thanks for the update. evolution-data-server is fine, it's in idle.
The evolution is stuck when reading the gnome-keyring password, and it matches bug #498871, thus I'm marking it as a duplicate.

*** This bug has been marked as a duplicate of bug 498871 ***

Note You need to log in before you can comment on or make changes to this bug.