Bug 510672 - Fails to start with ImportError: cannot import name _create_prefix
Fails to start with ImportError: cannot import name _create_prefix
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bzr-gtk (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Toshio Ernie Kuratomi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-10 04:28 EDT by Àlex Magaz Graça
Modified: 2009-07-28 14:25 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.96.2-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-28 14:24:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Àlex Magaz Graça 2009-07-10 04:28:49 EDT
Description of problem:

When Olive is run, it fails with the following traceback:

$ olive-gtk
/usr/lib/python2.5/site-packages/bzrlib/plugins/gtk/ui.py:224: DeprecationWarning: bzrlib.progress.ProgressBarStack was deprecated in version 1.12.
  self._progress_bar_stack = progress.ProgressBarStack(klass=widget)
Traceback (most recent call last):
  File "/usr/bin/olive-gtk", line 93, in <module>
    from bzrlib.plugins.gtk.olive import OliveGtk
  File "/usr/lib/python2.5/site-packages/bzrlib/plugins/gtk/olive/__init__.py", line 56, in <module>
    from bzrlib.plugins.gtk.push import PushDialog
  File "/usr/lib/python2.5/site-packages/bzrlib/plugins/gtk/push.py", line 29, in <module>
    from bzrlib.builtins import _create_prefix
ImportError: cannot import name _create_prefix

Version-Release number of selected component (if applicable):

bzr-gtk-0.95.0-2.fc10.i386

How reproducible:

Always.

Steps to Reproduce:
1. Run olive-gtk.
  
Actual results:

It crashes.

Expected results:

It starts normally.

Additional info:

It's fixed in the following patch:

http://bazaar.launchpad.net/%7Ebzr-gtk/bzr-gtk/trunk/diff/629
Comment 1 Fedora Update System 2009-07-10 21:41:45 EDT
bzr-gtk-0.96.2-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/bzr-gtk-0.96.2-1.fc11
Comment 2 Fedora Update System 2009-07-10 21:41:50 EDT
bzr-gtk-0.96.2-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/bzr-gtk-0.96.2-1.fc10
Comment 3 Toshio Ernie Kuratomi 2009-07-10 21:45:16 EDT
Sorry about that, I've been trying to get a compatible update together since bzr-1.16 came out.  This update should fix the 1.16 compatibility problems at least.
Comment 4 Àlex Magaz Graça 2009-07-14 06:08:26 EDT
It works. Thanks for fixing it so fast!!
Comment 5 Fedora Update System 2009-07-16 03:27:32 EDT
bzr-gtk-0.96.2-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bzr-gtk'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7667
Comment 6 Fedora Update System 2009-07-16 03:35:23 EDT
bzr-gtk-0.96.2-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bzr-gtk'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-7688
Comment 7 Fedora Update System 2009-07-28 14:24:06 EDT
bzr-gtk-0.96.2-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-07-28 14:25:17 EDT
bzr-gtk-0.96.2-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.