Bug 510688 - 400 Bad Request
400 Bad Request
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: tomcat5 (Show other bugs)
11
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Devrim GÜNDÜZ
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks: 554748
  Show dependency treegraph
 
Reported: 2009-07-10 05:40 EDT by Jan Kratochvil
Modified: 2010-06-28 09:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 554748 (view as bug list)
Environment:
Last Closed: 2010-06-28 09:33:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2009-07-10 05:40:55 EDT
Description of problem:
Always getting on http://localhost:8080 just 400 Bad Request.

Version-Release number of selected component (if applicable):
tomcat5-5.5.27-6.2.fc11.noarch
tomcat5-admin-webapps-5.5.27-6.2.fc11.noarch
tomcat5-common-lib-5.5.27-6.2.fc11.noarch
tomcat5-jasper-5.5.27-6.2.fc11.noarch
tomcat5-jasper-eclipse-5.5.27-6.2.fc11.noarch
tomcat5-jsp-2.0-api-5.5.27-6.2.fc11.noarch
tomcat5-server-lib-5.5.27-6.2.fc11.noarch
tomcat5-servlet-2.4-api-5.5.27-6.2.fc11.noarch
on F10.x86_64 tried:
tomcat-native-1.1.16-1.fc10.x86_64
tomcat5-5.5.27-6.1.fc10.noarch
tomcat5-admin-webapps-5.5.27-6.1.fc10.noarch
tomcat5-common-lib-5.5.27-6.1.fc10.noarch
tomcat5-jasper-5.5.27-6.1.fc10.noarch
tomcat5-jsp-2.0-api-5.5.27-6.1.fc10.noarch
tomcat5-server-lib-5.5.27-6.1.fc10.noarch
tomcat5-servlet-2.4-api-5.5.27-6.1.fc10.noarch

How reproducible:
Always.

Steps to Reproduce:
/etc/init.d/tomcat5 start
Firefox: http://127.0.0.1:8080/

Actual results:
Empty page.

Expected results:
Admin page.

Additional info:
GET / HTTP/1.1
Host: 127.0.0.1:8080
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1) Gecko/20090630 Fedora/3.5-1.fc11 Firefox/3.5
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: UTF-8,*
Keep-Alive: 300
Connection: keep-alive
Pragma: no-cache
Cache-Control: no-cache

HTTP/1.1 400 Bad Request
Server: Apache-Coyote/1.1
Transfer-Encoding: chunked
Date: Fri, 10 Jul 2009 08:47:57 GMT
Connection: close

0


Already tried to install (1) fresh full-DVD F10.x86_64 in KVM, (2) F10.x86_64 in chroot, (3) my native F11.x86_64 and all three are behaving the same. On one f10.x86_64 server it works out of the box.

strace does not show anything, /var/log/tomcat5/ does not contain any new interesting info, no new info is written there during the request, even after set all /etc/tomcat5/logging.properties *.level = ALL.
Comment 1 Jan Ščotka 2009-08-26 09:32:16 EDT
It seems like big problem. growing priority
Comment 3 Bug Zapper 2010-04-27 11:35:19 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2010-06-28 09:33:07 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.