Bug 510725 - Frequent dropped connection to OWA server
Frequent dropped connection to OWA server
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution-exchange (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-10 09:13 EDT by Matthew Saltzman
Modified: 2009-08-31 06:01 EDT (History)
2 users (show)

See Also:
Fixed In Version: evolution-exchange-2.26.3-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-31 06:01:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of evolution-exchange-storage for a session with a failure (2.28 KB, text/plain)
2009-07-10 22:25 EDT, Matthew Saltzman
no flags Details
Log of evolution from session with failure (1.30 KB, application/octet-stream)
2009-07-10 22:26 EDT, Matthew Saltzman
no flags Details
A second evo-exchange-storage log (3.66 KB, text/plain)
2009-07-11 08:02 EDT, Matthew Saltzman
no flags Details
A second evo log (1.03 KB, text/plain)
2009-07-11 08:05 EDT, Matthew Saltzman
no flags Details
Backtrace from breakpoint. (11.63 KB, text/plain)
2009-07-18 13:05 EDT, Matthew Saltzman
no flags Details
Bug Buddy log from "failed to refresh" crash. (21.49 KB, text/plain)
2009-07-26 13:14 EDT, Matthew Saltzman
no flags Details

  None (edit)
Description Matthew Saltzman 2009-07-10 09:13:43 EDT
Description of problem:
Evo frequently drops the connection to the OWA server when initializing or refreshing folder data.

Version-Release number of selected component (if applicable):
evolution-exchange-2.26.3-1.fc11.x86_64

How reproducible:
Frequently

Steps to Reproduce:
1. Open evo with an OWA account defined.
2. Wait for refresh or open new message or change folders.
3.
  
Actual results:
Failure to refresh folder or retrieve message due to dropped connection to OWA server.

Expected results:
Folder refreshes or message is retrieved.

Additional info:
This was occasionally a problem with evolution-exchange in F10, but is now much more frequent.  It often takes several startup/force-quit cycles to get a successful initialization.  Once initialization succeeds, the behavior is more reliable, but connection still drops on occasion.
Comment 1 Milan Crha 2009-07-10 10:11:40 EDT
Thanks for the bug report. Could you check whether it doesn't work because of evolution-exchange-storage crashed or not, as a starter, please?

You can try with these steps, for example:
a) close evolution
b) run: evolution --force-shutdown
c) on one console run: /usr/libexec/evolution/2.26/evolution-exchange-storage
d) and on other console run: evolution

Watch output on both consoles, for some error messages.
Comment 2 Matthew Saltzman 2009-07-10 22:25:16 EDT
Created attachment 351319 [details]
Log of evolution-exchange-storage for a session with a failure
Comment 3 Matthew Saltzman 2009-07-10 22:26:22 EDT
Created attachment 351320 [details]
Log of evolution from session with failure
Comment 4 Matthew Saltzman 2009-07-10 22:28:05 EDT
Attached simultaneous logs from evolution-exchage-storage and evolution for a session that failed.  This doesn't seem to be the only failure mode, but it is one that happened early in the session and produced some recognizable messages.

I'll keep watching for other failure modes, but meanwhile, HTH.
Comment 5 Matthew Saltzman 2009-07-11 08:02:17 EDT
Created attachment 351338 [details]
A second evo-exchange-storage log
Comment 6 Matthew Saltzman 2009-07-11 08:05:16 EDT
Created attachment 351339 [details]
A second evo log
Comment 7 Matthew Saltzman 2009-07-11 08:06:18 EDT
Added two more logs illustrating a "lost connection to back end" error.
Comment 8 Milan Crha 2009-07-13 04:28:04 EDT
Thanks for the update. I do not remember seeing this myself, nor before. My guess is that it became broken after
> camel-exchange-provider-CRITICAL **: camel-stub.c:558: Uncaught case (X)
on evolution's console.

Those failed assertions
> e_folder_exchange_propfind: assertion `E_IS_FOLDER_EXCHANGE (folder)' failed
from the first exchange's console shouldn't be there too, as they are not there in the second console snapshot. I guess these will be hard to catch, but it seems they are not as that much related to our issue.

Could you get the back trace of the "Uncaught case" warning, please?

You can do that by these steps:
a) close evolution
b) on console, run this command:
   $ gdb evolution --ex "b camel-stub.c:558" --ex r
   It'll ask you whether you want to add the breakpoint as a pending one,
   answer "y" there.
c) use evolution like before, until the gdb stops (evolution become unresponsive
   and on the console will be a gdb prompt, telling you it stopped
   in camel-stub.c:558). When it'll stop on some other place, just do "c" (like
   "continue") command in gdb.
d) in stopped gdb prompt invoke gdb command "t a a bt" and attach result here.

Thanks in advance.
Comment 9 Milan Crha 2009-07-13 05:55:44 EDT
There seems to be an upstream bug for it [1], but I miss there the other information I asked for above. Also the version it was originally reported against is quite old, so good you've a reproducer on more recent version.
We may use the uptream bug when it'll be confirmed it's the same thing.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=520556
Comment 10 Matthew Saltzman 2009-07-17 18:59:14 EDT
(In reply to comment #8)

I've been running this way today, and I'm still getting the "failure to update" and "lost connection", but the process is not stopping where you indicated.

Other developments:  I installed the debuginfo packages
evolution-debuginfo-2.26.3-1.fc11.x86_64
evolution-exchange-debuginfo-2.26.3-1.fc11.x86_64
evolution-data-server-debuginfo-2.26.3-1.fc11.x86_64
evolution-mapi-debuginfo-0.26.2-1.fc11.x86_64
Now I get frequent bug-buddy invocations.  These seem to mostly be dups of reports already in GNOME's Bugzilla.

gdb also wants a bunch more debuginfo packages:
Missing separate debuginfos, use: debuginfo-install GConf2-2.26.2-1.fc11.x86_64 ORBit2-2.14.17-1.fc11.x86_64 PackageKit-gtk-module-0.4.8-2.fc11.x86_64 alsa-lib-1.0.20-1.fc11.x86_64 atk-1.25.2-2.fc11.x86_64 avahi-0.6.25-3.fc11.x86_64 avahi-glib-0.6.25-3.fc11.x86_64 bluez-libs-4.37-2.fc11.x86_64 bug-buddy-2.26.0-2.fc11.x86_64 bzip2-libs-1.0.5-5.fc11.x86_64 cairo-1.8.6-2.fc11.x86_64 cyrus-sasl-lib-2.1.22-22.fc11.x86_64 db4-4.7.25-11.fc11.x86_64 dbus-glib-0.80-2.fc11.x86_64 dbus-libs-1.2.12-1.fc11.x86_64 e2fsprogs-libs-1.41.4-10.fc11.x86_64 elfutils-libelf-0.141-1.fc11.x86_64 enchant-1.4.2-5.fc11.x86_64 evolution-rss-0.1.2-10.fc11.x86_64 expat-2.0.1-6.x86_64 fontconfig-2.6.99.behdad.20090508-1.fc11.x86_64 freetype-2.3.9-3.fc11.x86_64 gamin-0.1.10-4.fc11.x86_64 geoclue-0.11.1.1-0.3.20090310git3a31d26.fc11.x86_64 glib2-2.20.3-1.fc11.x86_64 glibc-2.10.1-2.x86_64 gnome-keyring-2.26.1-1.fc11.x86_64 gnome-pilot-2.0.17-2.fc11.x86_64 gnome-vfs2-2.24.1-2.fc11.x86_64 gnutls-2.6.6-1.fc11.x86_64 gstreamer-0.10.23-2.fc11.x86_64 gstreamer-plugins-base-0.10.23-3.fc11.x86_64 gtk-nodoka-engine-0.7.2-4.fc11.x86_64 gtk2-2.16.2-1.fc11.x86_64 gtkhtml3-3.26.3-1.fc11.x86_64 gvfs-1.2.3-7.fc11.x86_64 hal-libs-0.5.12-26.20090226git.fc11.x86_64 hunspell-1.2.8-7.fc11.x86_64 keyutils-libs-1.2-5.fc11.x86_64 krb5-libs-1.6.3-20.fc11.x86_64 libICE-1.0.4-7.fc11.x86_64 libSM-1.1.0-4.fc11.x86_64 libX11-1.2.1-2.fc11.x86_64 libXau-1.0.4-5.fc11.x86_64 libXcomposite-0.4.0-7.fc11.x86_64 libXcursor-1.1.9-4.fc11.x86_64 libXdamage-1.1.1-6.fc11.x86_64 libXext-1.0.99.1-2.fc11.x86_64 libXfixes-4.0.3-5.fc11.x86_64 libXi-1.2.1-1.fc11.x86_64 libXinerama-1.0.3-4.fc11.x86_64 libXrandr-1.2.99.4-3.fc11.x86_64 libXrender-0.9.4-5.fc11.x86_64 libXt-1.0.5-2.fc11.x86_64 libart_lgpl-2.3.20-4.fc11.x86_64 libattr-2.4.43-3.fc11.x86_64 libbeagle-0.3.9-3.fc11.x86_64 libbonobo-2.24.1-1.fc11.x86_64 libbonoboui-2.24.1-1.fc11.x86_64 libcanberra-0.12-1.fc11.x86_64 libcanberra-gtk2-0.12-1.fc11.x86_64 libcap-2.16-4.fc11.1.x86_64 libcroco-0.6.2-2.fc11.x86_64 libgcc-4.4.0-4.x86_64 libgcrypt-1.4.4-6.fc11.x86_64 libglade2-2.6.4-1.fc11.x86_64 libgnome-2.26.0-1.fc11.x86_64 libgnomecanvas-2.26.0-1.fc11.x86_64 libgnomeui-2.24.1-1.fc11.x86_64 libgpg-error-1.6-3.x86_64 libgsf-1.14.11-3.fc11.x86_64 libical-0.43-4.fc11.x86_64 libicu-4.0.1-4.fc11.x86_64 libjpeg-6b-45.fc11.x86_64 libldb-0.9.3-14.fc11.x86_64 libnotify-0.4.5-2.fc11.x86_64 libogg-1.1.3-11.fc11.x86_64 libpng-1.2.37-1.fc11.x86_64 librsvg2-2.26.0-1.fc11.x86_64 libselinux-2.0.80-1.fc11.x86_64 libsoup-2.26.2-1.fc11.x86_64 libstdc++-4.4.0-4.x86_64 libtalloc-1.2.0-29.14.fc11.x86_64 libtasn1-1.8-2.fc11.x86_64 libtdb-1.1.3-14.fc11.x86_64 libtevent-0.9.3-14.fc11.x86_64 libtool-ltdl-2.2.6-11.fc11.x86_64 libusb-0.1.12-21.fc11.x86_64 libvorbis-1.2.0-7.fc11.x86_64 libxcb-1.2-4.fc11.x86_64 libxml2-2.7.3-2.fc11.x86_64 libxslt-1.1.24-4.fc11.x86_64 nspr-4.8-1.fc11.x86_64 nss-3.12.3-4.fc11.x86_64 nss-devel-3.12.3-4.fc11.x86_64 nss-softokn-freebl-3.12.3-4.fc11.x86_64 openchange-0.8.2-2.fc11.x86_64 openldap-2.4.15-3.fc11.x86_64 openssl-0.9.8k-5.fc11.x86_64 pango-1.24.2-1.fc11.x86_64 pilot-link-0.12.3-20.fc11.x86_64 pixman-0.14.0-2.fc11.x86_64 popt-1.13-5.fc11.x86_64 samba4-libs-4.0.0-14alpha7.fc11.x86_64 sqlite-3.6.12-3.fc11.x86_64 webkitgtk-1.1.8-1.fc11.x86_64 xulrunner-1.9.1-1.fc11.x86_64 zlib-1.2.3-22.fc11.x86_64
Comment 11 Matthew Saltzman 2009-07-18 13:05:00 EDT
Created attachment 354258 [details]
Backtrace from breakpoint.

As requested in comment #8.
Comment 12 Matthew Saltzman 2009-07-18 13:07:05 EDT
(In reply to comment #11)
> Created an attachment (id=354258) [details]
> Backtrace from breakpoint.
> 
> As requested in comment #8.  

This crash happened while I was away from the machine.  Evo stopped, but not at the breakpoint.  Then I entered 'c' and it started, then stopped at the breakpoint.
Comment 13 Milan Crha 2009-07-20 04:57:24 EDT
Thanks for the update. I was pointed to some other upstream bug [1] today, just by a chance, where there seem to be a patch available for the issue. Can you try to test a patch [2] yourself, or should I build a test package for you?

Note that your backtrace of the "Uncaught case" doesn't seem to touch code changes in the patch directly, but that's, I believe, just that the code returned the value.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=498099
[2] http://bugzilla.gnome.org/show_bug.cgi?id=522277#c11
Comment 14 Matthew Saltzman 2009-07-20 15:36:36 EDT
It would be great if you could build the test package.  I can probably do it, but I can't just whip them off like you surely can.  Thanks!
Comment 15 Milan Crha 2009-07-21 05:54:48 EDT
I created a test package at a testing repo, see [1]. Please try with this and let me know. Thanks in advance. Note, after installing of the package, please close evolution and invoke on the console: evolution --force-shutdown
It will ensure that you will use latest package binaries.

[1] https://admin.fedoraproject.org/updates/evolution-exchange-2.26.3-2.fc11
Comment 16 Matthew Saltzman 2009-07-21 17:00:59 EDT
I've been running with the test package all day today.  It's not perfect--I still get some crashes and some lost connections, sometimes occurring together--but it seems to be much better with the patch than without.  I'll post again once I have a bit more experience with it--including changing locations and restarting, which seemed to be a particular problem before.
Comment 17 Matthew Saltzman 2009-07-22 14:46:44 EDT
With some more experience, this seems better than before, but is definitely not the solution to all these problems.

I continue to have an assortment of crashes (bug-buddy invocations, some of which close evo entirely and some of which the evo session survives, but loses connectivity), failure to update folders, and lost Exchange backends.  These occur in batches when I start evo from scratch, but they stop after several restarts.  Once evo has settled down, the errors seem noticeably less frequent than before the patch, but they still occur occasionally.  Quitting and restarting may or may not result in another spate of errors.  That seems to depend on whether or not the inbox is being updated or filtered.
Comment 18 Milan Crha 2009-07-23 03:50:58 EDT
Do you have any backtraces of crashed evolution and/or evolution-exchange-storage process, please? Maybe try close evolution, then evolution --force-shutdown, then run evolution-exchange-storage process under gdb, like this:
   $ gdb /usr/libexec/evolution/2.26/evolution-exchange-storage --ex r
and then run evolution from some other console.
One possibility seeing "lost connection" can be that the evolution-exchange-storage crashed, but there are also other possibilities.

Some user stated in the upstream bug [1] that the clear of exchange data from ~/.evolution fixed the troubles for him, together with a patch from that bug.
Thinking of it, and in context of clues you wrote above, it really seems that there is something wrong with the local cache or summary of mails you have on the exchange server. Especially when it triggers mainly when filtering or downloading new messages. Of course, it can be within the code which is related to this operations and fresh fetch of message information from the server will not help at all. But please try, to eliminate one thing after the other. Thanks in advance.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=522277
Comment 19 Matthew Saltzman 2009-07-23 12:16:00 EDT
Working on resolving an unrelated server-side issue, but will clean the cache and try the above once that is settled.
Comment 20 Matthew Saltzman 2009-07-26 13:11:29 EDT
Caught one.  Nothing actually crashed, but the "failed to update" pop-up showed.

Oops, after a minute or so of doing nothing, evo crashed.  Console logs below.  Will attach Bug Buddy report next.

From the evo-excahnge-storage side:

(evolution-exchange-storage:11971): exchange-mail-WARNING **: got_folder: 7

** (evolution-exchange-storage:11971): WARNING **: renew_subscription: 1 Cancelled

** (evolution-exchange-storage:11971): WARNING **: renew_subscription: 1 Cancelled

** (evolution-exchange-storage:11971): WARNING **: renew_subscription: 1 Cancelled
[Thread 0x7fffecff2910 (LWP 12067) exited]

(evolution-exchange-storage:11971): evolution-exchange-storage-CRITICAL **: e_folder_exchange_search_start: assertion `E_IS_FOLDER_EXCHANGE (folder)' failed

** (evolution-exchange-storage:11971): CRITICAL **: e2k_result_iter_get_total: assertion `iter != NULL' failed

** (evolution-exchange-storage:11971): CRITICAL **: e2k_result_iter_next: assertion `iter != NULL' failed

** (evolution-exchange-storage:11971): CRITICAL **: e2k_result_iter_free: assertion `iter != NULL' failed

(evolution-exchange-storage:11971): exchange-mail-WARNING **: got_new_smtp_messages: 8

(evolution-exchange-storage:11971): evolution-exchange-storage-CRITICAL **: e_folder_exchange_propfind: assertion `E_IS_FOLDER_EXCHANGE (folder)' failed

(evolution-exchange-storage:11971): exchange-mail-WARNING **: got_sync_deleted_props: 8
-------------------No messages after the crash-------------------

From the evo side:

  
RSS Plugin enabled (evolution 2.26, evolution-rss 0.1.2)
** (evolution:11976): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:11976): DEBUG: mailto URL program: evolution

(evolution:11976): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display: assertion `atom != GDK_NONE' failed

(evolution:11976): composer-WARNING **: autosave load filename = "/home/mjs/.evolution/.evolution-composer.autosave-ZWL8WU"
restoring draft flag 'text/plain'

(evolution:11976): composer-WARNING **: autosave load filename = "/home/mjs/.evolution/.evolution-composer.autosave-1LWNXU"
restoring draft flag 'text/plain'
feed The Opinionator
feed Michael Trick's Operations Research Blog
feed Paul Krugman
feed Comments for Michael Trick's Operations Research Blog
feed The Climb

(evolution:11976): camel-WARNING **: Trying to check junk data is OBJECT 'CamelStream'

(evolution:11976): camel-CRITICAL **: camel_object_is: assertion `check_magic(o, ctype, CAMEL_OBJECT_MAGIC)' failed

(evolution:11976): camel-CRITICAL **: camel_stream_write: assertion `CAMEL_IS_STREAM (stream)' failed

(evolution:11976): camel-WARNING **: Trying to check junk data is OBJECT 'CamelStream'

(evolution:11976): camel-CRITICAL **: camel_object_is: assertion `check_magic(o, ctype, CAMEL_OBJECT_MAGIC)' failed

(evolution:11976): camel-CRITICAL **: camel_stream_close: assertion `CAMEL_IS_STREAM (stream)' failed

(evolution:11976): camel-WARNING **: Trying to check junk data is OBJECT 'CamelObject'

(evolution:11976): camel-CRITICAL **: camel_object_is: assertion `check_magic(o, ctype, CAMEL_OBJECT_MAGIC)' failed

(evolution:11976): camel-CRITICAL **: camel_object_unref: assertion `CAMEL_IS_OBJECT(o)' failed

(evolution:11976): camel-WARNING **: Trying to check junk data is OBJECT 'CamelStream'

(evolution:11976): camel-CRITICAL **: camel_object_is: assertion `check_magic(o, ctype, CAMEL_OBJECT_MAGIC)' failed

(evolution:11976): camel-CRITICAL **: camel_stream_write: assertion `CAMEL_IS_STREAM (stream)' failed

(evolution:11976): camel-WARNING **: Trying to check junk data is OBJECT 'CamelStream'

(evolution:11976): camel-CRITICAL **: camel_object_is: assertion `check_magic(o, ctype, CAMEL_OBJECT_MAGIC)' failed

(evolution:11976): camel-CRITICAL **: camel_stream_close: assertion `CAMEL_IS_STREAM (stream)' failed

(evolution:11976): camel-WARNING **: Trying to check junk data is OBJECT 'CamelObject'

(evolution:11976): camel-CRITICAL **: camel_object_is: assertion `check_magic(o, ctype, CAMEL_OBJECT_MAGIC)' failed

(evolution:11976): camel-CRITICAL **: camel_object_unref: assertion `CAMEL_IS_OBJECT(o)' failed
feed sci.op-research Google Group
feed FiveThirtyEight.com: Electoral Projections Done Right

(evolution:11976): camel-WARNING **: Trying to check junk data is OBJECT 'CamelStream'

(evolution:11976): camel-CRITICAL **: camel_object_is: assertion `check_magic(o, ctype, CAMEL_OBJECT_MAGIC)' failed

(evolution:11976): camel-CRITICAL **: camel_stream_write: assertion `CAMEL_IS_STREAM (stream)' failed

(evolution:11976): camel-WARNING **: Trying to check junk data is OBJECT 'CamelStream'

(evolution:11976): camel-CRITICAL **: camel_object_is: assertion `check_magic(o, ctype, CAMEL_OBJECT_MAGIC)' failed

(evolution:11976): camel-CRITICAL **: camel_stream_close: assertion `CAMEL_IS_STREAM (stream)' failed

(evolution:11976): camel-WARNING **: Trying to check junk data is OBJECT 'CamelObject'

(evolution:11976): camel-CRITICAL **: camel_object_is: assertion `check_magic(o, ctype, CAMEL_OBJECT_MAGIC)' failed

(evolution:11976): camel-CRITICAL **: camel_object_unref: assertion `CAMEL_IS_OBJECT(o)' failed
feed NYT > NYTimes.com Home
image cache MISS

(evolution:11976): camel-WARNING **: Trying to check junk data is OBJECT 'CamelStream'

(evolution:11976): camel-CRITICAL **: camel_object_is: assertion `check_magic(o, ctype, CAMEL_OBJECT_MAGIC)' failed

(evolution:11976): camel-CRITICAL **: camel_stream_write: assertion `CAMEL_IS_STREAM (stream)' failed

(evolution:11976): camel-WARNING **: Trying to check junk data is OBJECT 'CamelStream'

(evolution:11976): camel-CRITICAL **: camel_object_is: assertion `check_magic(o, ctype, CAMEL_OBJECT_MAGIC)' failed

(evolution:11976): camel-CRITICAL **: camel_stream_close: assertion `CAMEL_IS_STREAM (stream)' failed

(evolution:11976): camel-WARNING **: Trying to check junk data is OBJECT 'CamelObject'

(evolution:11976): camel-CRITICAL **: camel_object_is: assertion `check_magic(o, ctype, CAMEL_OBJECT_MAGIC)' failed

(evolution:11976): camel-CRITICAL **: camel_object_unref: assertion `CAMEL_IS_OBJECT(o)' failed
image cache MISS

 Error syncing up the countsMaking error
Network timeout occured. Cancel active operations.
--------------------Then the crash...---------------
Missing separate debuginfo for /usr/lib64/libtdb.so.1
Try: yum --enablerepo='*-debuginfo' install /usr/lib/debug/.build-id/56/1175f4b142f66a751e5f31b5f5726780123787.debug
Comment 21 Matthew Saltzman 2009-07-26 13:14:32 EDT
Created attachment 355206 [details]
Bug Buddy log from "failed to refresh" crash.
Comment 22 Milan Crha 2009-07-27 06:10:20 EDT
Thanks for the update. The crashing thread is below. I'm more and more confident that the issue is related to
> ** (evolution-exchange-storage:11971): WARNING **: renew_subscription: 1
> Cancelled

because, if I recall correctly, the evolution-exchange doesn't work well with cancelling. Maybe, when the renew_subscription would not be cancelled, then the process would work properly. I've no clue here.

Thread 2 (Thread 0x7f0d421fc910 (LWP 12174)):
#4  <signal handler called>
#5  0x0000003d47e82803 in memcpy () from /lib64/libc.so.6
#6  0x00007f0d8a0b97ac in marshal_read (marshal=0x7f0d80002c00, 
    buf=0x7f0c898f8010 "\200...", len=-1208992900)
    at /usr/include/bits/string3.h:52
#7  0x00007f0d8a0b9bf5 in decode_string (marshal=0x7f0d80002c00, 
    str=0x7f0d421fbd30) at camel-stub-marshal.c:242
#8  0x00007f0d8a0b9ed9 in camel_stub_marshal_decode_string (
    marshal=0x7f0c899bd7d4, str=0x7f0d80102fd0) at camel-stub-marshal.c:318
#9  0x00007f0d8a0ba73c in stub_send_internal (stub=0x24dede0, 
    ex=<value optimized out>, oneway=0, command=<value optimized out>, 
    ap=0x7f0d421fbd80) at camel-stub.c:511
#10 0x00007f0d8a0baa37 in camel_stub_send (stub=0x7f0c899bd7d4, 
    ex=0x7f0d80102fd0, command=<value optimized out>) at camel-stub.c:608
#11 0x00007f0d8a0b6ff3 in exchange_get_folder_info (
    store=<value optimized out>, top=0x0, flags=1, ex=0x7f0d8003bce0)
    at camel-exchange-store.c:748
#12 0x00007f0da4539d01 in camel_store_get_folder_info (store=0x21785d0, 
    top=0x0, flags=7, ex=0x7f0d8003bce0) at camel-store.c:894
#13 0x00007f0d9b85fe68 in get_folderinfo_exec (m=0x7f0d8003bcc0)
    at mail-ops.c:1075
#14 0x00007f0d9b85d0ef in mail_msg_proxy (msg=0x7f0d8003bcc0) at mail-mt.c:520
#15 0x00000036eaa61f32 in ?? () from /lib64/libglib-2.0.so.0
#16 0x00000036eaa60934 in ?? () from /lib64/libglib-2.0.so.0
#17 0x0000003d48a0686a in start_thread () from /lib64/libpthread.so.0
#18 0x0000003d47ede25d in clone () from /lib64/libc.so.6
#19 0x0000000000000000 in ?? ()
Comment 23 Fedora Update System 2009-08-01 19:52:43 EDT
evolution-exchange-2.26.3-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 Milan Crha 2009-08-31 06:01:55 EDT
Closing per comment #23

Note You need to log in before you can comment on or make changes to this bug.