Bug 510726 - No wired connection unless running dhclient manualy
No wired connection unless running dhclient manualy
Status: CLOSED DUPLICATE of bug 498207
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-10 09:14 EDT by Simon Schampijer
Modified: 2009-11-19 19:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-19 19:23:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (207.89 KB, text/plain)
2009-07-10 09:14 EDT, Simon Schampijer
no flags Details

  None (edit)
Description Simon Schampijer 2009-07-10 09:14:34 EDT
Created attachment 351259 [details]
/var/log/messages

Description of problem:
After starting the machine it does not connect to the wired interface. The device is up but is not associated - I have no IP address. When I run dhclient I can get an IP address fine and the connection is working. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
No wired connection unless running dhclient manualy

Expected results:


Additional info:
It looks like it is a driver issue - as I do not have this issue with the same release on other hardware. The laptop is a FUJITSU SIEMENS, LIFEBOOK C1410, Kernel: 2.6.29.5-191.fc11.i686.PAE, the network interfaces are:

02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8055 PCI-E Gigabit Ethernet Controller (rev 12)
05:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

Attached is the output of /var/log/messages
Comment 1 Niels Haase 2009-07-11 06:52:32 EDT
Thanks for filling this bug. 
Can you please provide the output of 'nm-tool' and the /etc/sysconfig/networking/profiles/default/ifcfg-eth0 configuration file? Thank you

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Simon Schampijer 2009-07-11 07:44:57 EDT
Thanks for the quick reply. I can get the output on Monday when I have access to that machine again. Please let me know any other information I should provide or things I can test. 

From the log it suggest that the authentication after "(eth0): device state change: 2 -> 3" does not happen, so yeah - maybe the configs do not suggest to do so.
Comment 3 Simon Schampijer 2009-07-13 04:13:53 EDT
nm-tool output:

NetworkManager Tool

State: disconnected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            sky2
  State:             disconnected
  Default:           no
  HW Address:        00:17:42:6D:96:4B

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on


- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath5k
  State:             disconnected
  Default:           no
  HW Address:        00:16:44:1D:19:15

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points 
    drhouse:         Infra, 00:1C:F0:70:AE:58, Freq 2412 MHz, Rate 54 Mb/s, Strength 8 WPA2


----------
There are no configuration files in /etc/sysconfig/networking/profiles/default/ at all.
Comment 4 Simon Schampijer 2009-07-13 05:43:02 EDT
In the etc/sysconfig/network-scripts/ifcfg-eth0 config file ONBOOT was set to no. Changed that to yes and the device was up on boot. 

I am a bit confused what the difference is between the networking/ network-scripts/ . Is the networking one the current one? 

system-config-network-1.5.97/src/netconfpkg/NC_functions.py:70:OLDSYSCONFDEVICEDIR = '/etc/sysconfig/network-scripts/'
system-config-network-1.5.97/src/netconfpkg/NC_functions.py:71:SYSCONFNETWORKING = '/etc/sysconfig/networking/'

Who does us them? NM as well?
Comment 5 Niels Haase 2009-07-14 17:45:56 EDT
(In reply to comment #4)
> In the etc/sysconfig/network-scripts/ifcfg-eth0 config file ONBOOT was set to
> no. Changed that to yes and the device was up on boot. 

Solve the setting of ONBOOT=yes your problem entirely?

> 
> I am a bit confused what the difference is between the networking/
> network-scripts/ . Is the networking one the current one? 
> 
> system-config-network-1.5.97/src/netconfpkg/NC_functions.py:70:OLDSYSCONFDEVICEDIR
> = '/etc/sysconfig/network-scripts/'
> system-config-network-1.5.97/src/netconfpkg/NC_functions.py:71:SYSCONFNETWORKING
> = '/etc/sysconfig/networking/'
> 
> Who does us them? NM as well?

All the files in /etc/sysconfig/networking/{devices,profile} are hardlinked with the one under /etc/sysconfig/network-scripts. They are the same (please see the comparison of the inode)

find /etc/sysconfig -links +1 -type f -exec ls -i {} \;

71068 /etc/sysconfig/networking/devices/ifcfg-B63
63 /etc/sysconfig/networking/devices/ifcfg-eth0
71068 /etc/sysconfig/networking/profiles/default/ifcfg-B63
1641 /etc/sysconfig/networking/profiles/default/hosts
63 /etc/sysconfig/networking/profiles/default/ifcfg-eth0
71068 /etc/sysconfig/network-scripts/ifcfg-B63
63 /etc/sysconfig/network-scripts/ifcfg-eth0


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Simon Schampijer 2009-09-09 04:03:14 EDT
Ok, I have seen this today on another machine. When there is a network login (ldap) it is important that the device is up after booting. Setting ONBOOT=yes was again what made it work for me. 

I guess for some reason, the option was not set, as I see on other machines the flag set.
Comment 7 Dan Williams 2009-11-19 19:23:56 EST
If you don't use the network for the install (ie, install off the DVD), then the installer will not set ONBOOT=yes for the interfaces, because it presumes that since you didn't use the network for the install, that you dont' want it started up automatically after that.  A false assumption perhaps...

*** This bug has been marked as a duplicate of bug 498207 ***

Note You need to log in before you can comment on or make changes to this bug.