Bug 510759 - pgmtopbm broken
pgmtopbm broken
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: netpbm (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Jindrich Novy
Petr Šplíchal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-10 11:55 EDT by Petr Šplíchal
Modified: 2016-05-31 21:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 565488 (view as bug list)
Environment:
Last Closed: 2012-02-21 01:48:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Šplíchal 2009-07-10 11:55:55 EDT
Description of problem:

pgmtopbm does not correctly convert grayscale pgm images to black
& white pbm images, instead produces an empty white image.

Version-Release number of selected component (if applicable):
netpbm-10.35.58-8.el5.x86_64

Steps to Reproduce:
$ ppmwheel 300 | ppmtopgm | pgmtopbm > img.pbm
view the image or display histogram using
$ ppmhist img.pbm
  
Actual results:
   r     g     b   	 lum 	 count  
 ----- ----- ----- 	-----	------- 
     1     1     1	    1	  90000 

Expected results:
   r     g     b   	 lum 	 count  
 ----- ----- ----- 	-----	------- 
     1     1     1	    1	  64456 
     0     0     0	    0	  25544 

Additional info:
Works ok on Fedora 10 (netpbm-10.35.64-1.fc10.i386).
Comment 1 Jonathan Kamens 2010-04-01 14:24:37 EDT
Broken in F13 (x86_64).
Comment 3 RHEL Product and Program Management 2010-08-09 15:14:45 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2011-05-31 10:31:01 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 9 errata-xmlrpc 2012-02-21 01:48:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0287.html

Note You need to log in before you can comment on or make changes to this bug.