Bug 5108 - ppp failure pops up Red Hat registration box
ppp failure pops up Red Hat registration box
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-13 14:36 EDT by ericchang
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-14 11:43:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ericchang 1999-09-13 14:36:54 EDT
PPP annoyances.  Of course, since this was a RedHat
distribution, PPP required the user to be root to open a
connection.  Although this is a VFAQ, and it is covered in
the PPP HOWTO, it is still a usability issue.  It could be
very confusing to the new user, especially one who did not
have to wrestle with chmod u+s and privilige issues under
Windows.  Also, the paths are not found for a regular user.
The workaround for this is to type the full path
(/usr/sbin/ppp-on etc.) but then the user can rightfully
ask why it is not simpler.  The workaround for this is to
set up links in the user's home/bin directory, but this is
complicated, and usually requires a site visit (very
inconvenient).

One even more annoying thing, which resulted in an
unpleasant late night service call, was the cryptic nature
of PPP failure.  If PPP fails to connect,  ppp-on should
terminate with the message "PPP call failed".  That is the
least it should do.  Actually, it should pop a dialog box
that tells why there was a problem.  Using /sbin/ifconfig,
then browsing the log file for messages is too unfriendly
for the non-Unix guru.  When the failure occurred, the
first symptom noted was that a dialog box popped up
suggesting that the user register the software with the
RedHat site.  First, this was not a packaged CDROM install,
so registration was not an issue.  Second, it never should
have asked for registration, since registration cannot be
performed when the link is malfunctioning.  Third, nag
boxes are intrusive, even if they are called for.  Fourth,
this is not the appropriate error message.  "PPP call
failed" is the appropriate error message.  Closing the
dialog box worked, but then no sites were accessible.
Accessing them failed with the ubiquitous DNS address not
found error.  Again, this is not the problem.  The ppp
call failed.  This was probably due to the ISP, but it
was certainly not due to the fact that the software had
not been registered with RedHat.  The software does not
need to be registered, and without an ID number, it cannot
even be registered with RedHat.
Comment 1 David Lawrence 1999-09-14 11:43:59 EDT
PPP connections are being worked on to be more intuitive and user
friendly for the next release. Until then the method we use most often
to bring up and down ppp interfaces is to treat it like a normal
network device. Using netconfig or linuxconf, it creates a
/etc/sysconfig/network-scripts/ifcfg-ppp0 and
/etc/sysconfig/network-scripts/chat-ppp0 which has all the necessary
information in them. Netconfig and linuxconf also ask if users should
be allowed to bring this interface up and therefore will allow normal
users to type ifup ppp0 and ifdown ppp0 without being root.

Note You need to log in before you can comment on or make changes to this bug.